2002 Trooper cruise control problem

Use this forum to discuss audio and electronic upgrades for your Isuzu

Moderator: Staff

2002 Trooper cruise control problem

Postby dbracht » Tue Feb 23, 2016 1:44 am

Looking for some advice on a recent issue with my cruise control. 2002 Trooper auto transmission. Suddenly it quite working. If I push the switch on the dash it lights up in the instrument cluster. When a push the button on the right stalk it does not set and the other dash light does not come on anymore. I replaced the dash switch with one off ebay but that didn't fix it. Any suggestions on what to look for? Thank you for any responses or advice
dbracht
Drives on Pavement
 
Posts: 2
Joined: Mon Oct 27, 2014 11:48 pm
Has thanked: 0 time
Have thanks: 0 time

Sponsor
 

Re: 2002 Trooper cruise control problem

Postby country boy » Tue Feb 23, 2016 11:24 am

My 2000 did the same thing. I could not figure it out. Just as suddenly it started working again and it has been OK for the last several hundred miles. I just turned it on and check it and it would not work for about 2 weeks then OK again.
2000 Trooper/ first Isuzu and I love it
country boy
Mi Amigo
 
Posts: 171
Joined: Thu Dec 04, 2014 4:47 pm
Location: La Crosse Va
Has thanked: 34 times
Have thanks: 3 times

Re: 2002 Trooper cruise control problem

Postby radare » Fri Feb 26, 2016 12:24 pm

Does your speedometer work, your gear indicator show the correct gear, and your brake lights work as appropriate?
'94 Isuzu Rodeo 4WD, 3.2L V6. 156k miles (Sold); '01 Isuzu Rodeo LS 4WD, 3.2L V6, 108k miles (Sold).
Currently restoring an '01 Rodeo Sport V6
My other passion: My Yamaha XJ600 and XJ600 Scrambler
User avatar
radare
Trail Master
 
Posts: 598
Joined: Wed Dec 01, 2004 2:59 pm
Location: Denver, CO
Has thanked: 25 times
Have thanks: 53 times

Re: 2002 Trooper cruise control problem

Postby country boy » Sat Feb 27, 2016 4:03 pm

Yes everything else worked. I was thinking about this on my trip and the only work I did was clean my EGR tube and had to unplug the connection at the throttle body. Plugged it back in . Do not know if that is relevant.
2000 Trooper/ first Isuzu and I love it
country boy
Mi Amigo
 
Posts: 171
Joined: Thu Dec 04, 2014 4:47 pm
Location: La Crosse Va
Has thanked: 34 times
Have thanks: 3 times

Re: 2002 Trooper cruise control problem

Postby dbracht » Thu Mar 03, 2016 12:13 am

radare wrote:Does your speedometer work, your gear indicator show the correct gear, and your brake lights work as appropriate?


Ok figured it out. Thank you radare for this post as it got me looking in the right direction. A few months ago I noticed a brake light was out. I replaced both sides with LED 1157 bulbs I bought at Walmart. This post got me thinking about those bulbs. This week I put in new regular bulbs and that fixed it. Works now fine. Thanks again for the advice it truly helped.. :D
dbracht
Drives on Pavement
 
Posts: 2
Joined: Mon Oct 27, 2014 11:48 pm
Has thanked: 0 time
Have thanks: 0 time

Re: 2002 Trooper cruise control problem

Postby btjans » Sun Mar 13, 2016 8:04 pm

My CC was working fine, then the first time I tried to use it after I had the transmission rebuilt, it won't engage. The CC indicator light comes on, but it won't set or do anything with the other buttons. Could it be that they disconnected something when hey worked on the tranny? Thanks
btjans
Drives on Pavement
 
Posts: 10
Joined: Wed Jan 27, 2016 4:01 pm
Has thanked: 1 time
Have thanks: 0 time

Re: 2002 Trooper cruise control problem

Postby Tomzu » Fri Jan 29, 2021 11:52 pm

btjans wrote:My CC was working fine, then the first time I tried to use it after I had the transmission rebuilt, it won't engage. The CC indicator light comes on, but it won't set or do anything with the other buttons. Could it be that they disconnected something when hey worked on the tranny? Thanks


Howdy, I just bought a 2002 Isuzu Trooper and tried my cruise control today and the cruise light comes on when I flick the button on the dash... but when I go to set it by clicking the set button the Cruise Set light flashes on for a second and then goes out. I do have a brake light out I'm going to replace it tomorrow, BUT also the transmission was recently rebuilt. Anybody know anymore about this or have/fixed an issue like this? Thanks!!
Tomzu
Drives on Pavement
 
Posts: 8
Joined: Sun Jan 24, 2021 1:51 pm
Has thanked: 4 times
Have thanks: 0 time

Re: 2002 Trooper cruise control problem

Postby Tomzu » Sun Jan 31, 2021 2:32 am

Turned out to be a bad brake/tail light. Once I replaced all is working again! Thanks again all!!
Tomzu
Drives on Pavement
 
Posts: 8
Joined: Sun Jan 24, 2021 1:51 pm
Has thanked: 4 times
Have thanks: 0 time

Re: 2002 Trooper cruise control problem

Postby bsarles » Sat Mar 20, 2021 5:05 pm

My CC was all jacked up with it holding the proper speed, turned out the tube to the EGR in the 3.2 plenum was clogged so bad that it caused the CC to do random things. Technically it functioned and ran but not correctly. I’ll keep in mind about the lightbulbs, why the holy hell would they wire a vehicle in such away that if a bulb went out it would not allow the CC to work. That’s nutso engineering.
bsarles
Drives on Gravel
 
Posts: 40
Joined: Tue Jul 30, 2013 10:27 pm
Has thanked: 0 time
Have thanks: 0 time

Re: 2002 Trooper cruise control problem

Postby Buster28 » Wed Mar 24, 2021 10:13 am

bsarles wrote:I’ll keep in mind about the lightbulbs, why the holy hell would they wire a vehicle in such away that if a bulb went out it would not allow the CC to work. That’s nutso engineering.

The tail lamp and the brake (stop) lamp is a dual filament bulb with a common ground. If the shell of bulb becomes corroded the ground path resistance for the circuit increases, this electrically causes the two filaments to be connected in series.

The foot brake switch is connected to the brake lamp filament and the cruise control module. Applying the foot brake places +12 Vdc on this connection causing the brake lamps to illuminate and cruise to disengage.

However, if the tail lamp and the brake lamp filaments get connected in series due a corroded ground shell on bulb, turning On the tail lamps will connect +12 Vdc to the brake lamp circuit through the series tail lamp filament connection. This causes the brake lamp to illuminate and cruise to become inoperative when the tail lamps are illuminated. I have had this happen with my Rodeo.
2002 Rodeo Sport 4X4 3.2L V6
2020 Jeep Wrangler 2dr 4x4 3.6L V6
User avatar
Buster28
4L30E Guru
 
Posts: 11509
Joined: Fri Dec 18, 2009 12:28 pm
Location: RI
Has thanked: 10 times
Have thanks: 1308 times


Who is online

Users browsing this forum: No registered users and 9 guests