Blower motor problem

Use this forum to discuss audio and electronic upgrades for your Isuzu

Moderator: Staff

Blower motor problem

Postby Wmamula04 » Mon Apr 05, 2021 7:22 pm

my 91 Trooper is having a blower motor issue. It has no power once so ever to the motor. I believe I’ve checked every fuse and relay and they all seem fine. The motor itself is fine as well. Any ideas on what could be the problem?
Wmamula04
Drives on Pavement
 
Posts: 8
Joined: Tue Nov 24, 2020 2:46 pm
Location: Somewhere in Colorado
Has thanked: 2 times
Have thanks: 0 time

Sponsor
 

Re: Blower motor problem

Postby Tentin » Mon Apr 05, 2021 7:33 pm

Blower motor resistor? Sounds like what I'm dealing with right now on my amigo. I unplugged it and bypassed it with a jumper wire so I have full on and full off (just no speed control) until my new part arrives.
1995 Isuzu Pickup 4WD aka Suzie Q. 3" lift, 32" A/T's
1998 Isuzu Amigo 4WD aka Smeagol The Amigo. 2" Lift, 31" A/T's
User avatar
Tentin
Loyal P'up
 
Posts: 128
Joined: Tue Jun 23, 2020 3:03 am
Location: San Jose
Has thanked: 0 time
Have thanks: 11 times

Re: Blower motor problem

Postby Wmamula04 » Mon Apr 05, 2021 7:57 pm

Tentin wrote:Blower motor resistor? Sounds like what I'm dealing with right now on my amigo. I unplugged it and bypassed it with a jumper wire so I have full on and full off (just no speed control) until my new part arrives.

Where is the resistor? I’m not too sure if I checked that.
Wmamula04
Drives on Pavement
 
Posts: 8
Joined: Tue Nov 24, 2020 2:46 pm
Location: Somewhere in Colorado
Has thanked: 2 times
Have thanks: 0 time

Re: Blower motor problem

Postby Tentin » Mon Apr 05, 2021 9:34 pm

On the drivers side by the heater box I believe for a 1st gen. Newer ones have it behind the glovebox right next to the blower motor.
1995 Isuzu Pickup 4WD aka Suzie Q. 3" lift, 32" A/T's
1998 Isuzu Amigo 4WD aka Smeagol The Amigo. 2" Lift, 31" A/T's
User avatar
Tentin
Loyal P'up
 
Posts: 128
Joined: Tue Jun 23, 2020 3:03 am
Location: San Jose
Has thanked: 0 time
Have thanks: 11 times

Re: Blower motor problem

Postby mudoilngears » Mon Apr 05, 2021 10:07 pm

The resistor pack is only used on speeds 1-3. 4 is full battery power to the motor. If 4 does not work it is unlikely to be a resistor failure.
Image
1998 Rodeo LS 4x4 4JB1-TC Diesel Swap, Moog CC247 coils, more mods to come!

SOLD- :( 1990 Isuzu Amigo 4X4 4ZE1 engine. Front Aussie Locker, HD Sway Away T-bars,Smittybilt XRC8 winch.
Build in progress...
User avatar
mudoilngears
Almost Joe Isuzu
 
Posts: 2207
Joined: Sun Jun 17, 2012 9:49 pm
Location: Costa Rica
Has thanked: 19 times
Have thanks: 179 times

Re: Blower motor problem

Postby Wmamula04 » Tue Apr 06, 2021 7:39 pm

mudoilngears wrote:The resistor pack is only used on speeds 1-3. 4 is full battery power to the motor. If 4 does not work it is unlikely to be a resistor failure.

It has 5 settings including off. If it’s unlikely to be a resistor what should I try next?
Wmamula04
Drives on Pavement
 
Posts: 8
Joined: Tue Nov 24, 2020 2:46 pm
Location: Somewhere in Colorado
Has thanked: 2 times
Have thanks: 0 time

Re: Blower motor problem

Postby JoeIsuzu » Tue Apr 06, 2021 8:05 pm

Is the charge warning relay getting current? Is current coming out?

Jack
Original owner, 1983 Isuzu P'up LS Diesel. Engine overhauled by JLEMOND. Ready for new paint now!
1994 Isuzu Amigo 2wd
IsuzuPup.com
"There are no dumb questions"?! Maybe not...
but there are smart ways to ask. Old, but classic:
How To Ask Questions The Smart Way
JoeIsuzu
Almost Joe Isuzu
 
Posts: 2573
Joined: Fri Jul 13, 2007 9:37 pm
Location: Germantown (next to Elvistown), TN
Has thanked: 122 times
Have thanks: 115 times

Re: Blower motor problem

Postby Tentin » Tue Apr 06, 2021 9:24 pm

Mine was a 5 pin too. Try a jumper wire on the connector from the "off" wire (should be center) to one of the other wires, then set your fan to that setting and see if it turns on. It'll be full blast since there's no resistor but should tell you that if it works that your resistor is fried. Mine was completely toast probably caused by the blower motor being seized, which I took apart and relubed.
1995 Isuzu Pickup 4WD aka Suzie Q. 3" lift, 32" A/T's
1998 Isuzu Amigo 4WD aka Smeagol The Amigo. 2" Lift, 31" A/T's
User avatar
Tentin
Loyal P'up
 
Posts: 128
Joined: Tue Jun 23, 2020 3:03 am
Location: San Jose
Has thanked: 0 time
Have thanks: 11 times

Re: Blower motor problem

Postby Wmamula04 » Tue Apr 06, 2021 9:56 pm

JoeIsuzu wrote:Is the charge warning relay getting current? Is current coming out?

Jack

Not to sure on where or what that is haha
Wmamula04
Drives on Pavement
 
Posts: 8
Joined: Tue Nov 24, 2020 2:46 pm
Location: Somewhere in Colorado
Has thanked: 2 times
Have thanks: 0 time

Re: Blower motor problem

Postby Wmamula04 » Tue Apr 06, 2021 9:58 pm

If it helps at all I have been having issues with my battery charging. The alternator still puts out the correct voltage however
Wmamula04
Drives on Pavement
 
Posts: 8
Joined: Tue Nov 24, 2020 2:46 pm
Location: Somewhere in Colorado
Has thanked: 2 times
Have thanks: 0 time


Who is online

Users browsing this forum: No registered users and 4 guests