Having trouble replacing 99 climate control HELP!

This forum is for the discussion of general Isuzu related information

Moderator: Staff

Having trouble replacing 99 climate control HELP!

Postby Hesher » Wed May 20, 2020 9:01 pm

Went to salvage yard to get a climate control for my 99 rodeo I bought. The back connector on it was big and white instead of 2 prong and green. The HARDEST part I'm having trouble with are the cables you have to put in place with the clip retainers. I'm trying my hands, needlenose, I can not seem to get them into place. Also it seems like on some rodeos you need 2 and some have 3? Not sure, and of course I can't find a video online of people actually replacing them part for part. Any help is appreciated as I'm slowly going insane.
Hesher
Drives on Dirt
 
Posts: 67
Joined: Sat Jan 13, 2018 10:21 pm
Has thanked: 0 time
Have thanks: 1 time

Sponsor
 

Re: Having trouble replacing 99 climate control HELP!

Postby Hesher » Wed May 20, 2020 9:10 pm

Image for context the top right plug in is was im talking about. This one is like 6-8 prong and white. The one on the 99 is 2 prong and green. Is this for the lights? Can anyone tell me?
Hesher
Drives on Dirt
 
Posts: 67
Joined: Sat Jan 13, 2018 10:21 pm
Has thanked: 0 time
Have thanks: 1 time

Re: Having trouble replacing 99 climate control HELP!

Postby Claytonervin2397 » Fri May 22, 2020 1:03 pm

No one? :(
Claytonervin2397
Drives on Pavement
 
Posts: 5
Joined: Tue Oct 30, 2018 2:36 pm
Has thanked: 0 time
Have thanks: 0 time


Return to General Isuzu Discussion

Who is online

Users browsing this forum: Guitarbuilder and 14 guests