Isuzu SUV Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I have a 2001 trooper 3.2 with 4l30e. Trans went out years ago and took it and rebuild kit to a reputable shop and they rebuilt it and could never get it to build pressure correctly so they gave up after $2500 or more. So I look on Craigslist and found a rebuilt transmission that a guy was going to use but motor blew. Had new seals everywhere so it did look like it was rebuilt and they guy had a nice shop. Put it in this weekend and it’s doing something I have never seen before. Goes in reverse strong no slipping. While in D it only moves slightly when revved way up. 3 nothing. 2 just like it should no slipping. L nothing. Switched the gear selector from old trans still the same. Winter mode has no effect. I’m lost. Couldn’t find anything like this on the site.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Looking at a wiring diagram would these symptoms Occur if the 4 pin plug is not plugged in? I’m not with the truck right now?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
Would the brake band effect all forward gears? Want to know before I drop pan AGAIN
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #9 ·
Ok. 2nd seems fine so that eliminates the brake band. What would you check first with the symptoms I described above? Does it sound like it’s more something in the valve body? Don’t want to drop trans again. I will probably sell it before that. Only got 118,000
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #11 ·
If you don't have 1st gear how did you get the truck moving and get up to speed for the transmission to shift into 2nd gear. There is no shift mode that allows for a 2nd gear start?
In 2 not D. Or does it start out in 2nd in 2 or 1st then 2nd. I drove it in 2 it never changed.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #12 ·
In 2 not D. Or does it start out in 2nd in 2 or 1st then 2nd. I drove it in 2 it never changed.
Sorry missed the last of your post. Would the gear selector do this if it’s not adjusted correctly. I had 2 and both did same thing.
 
1 - 7 of 7 Posts
Top