Isuzu SUV Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Ok, ive had this problem for awhile now and cant seem to figure out what it is. Ive had several things installed in my car and since that last upgrade, it was running fine for about 2 weeks, then the car just died. I can jump it, but when i go to turn on my compressors the car dies out. Everytime i go to turn up my system, the stereo turns off on its own like it dosent have enough power to hit the hard notes!! so i got a optima gel cell battery and put in a chrome 200 amp alternator and it started right up till the battery completely drained out again!!! I jumped it again and it stays started, but i cant turn on any accesories, and as soon as i turn the car off, it wont start back up!! So the alternator is not keeping the battery charged!! Does anyone know what else it could be? Is there something shorting out my battery so it wont charge properly? could it be a bad alternator? how can i check? any help please would be greatly appreciated!! :lol:
 

· Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanx for the input!! Unforunately, it does not have a volt meter!! I used the same belt from stock, and it was a tight fit because the tensioner is pretty much as tight as it can get, so I'm thinking pretty sure the belt isnt slipping! Whats another way i can find out if its not spinning fast enough? and if this is the problem, how can i fix it? the latest thing i did was the alternator and the new battery, but the problem didnt start happening till I installed my air suspension (this was before the alternator and the battery) and this is the reason I had to upgrade my battery and alternator! But when I upgraded them, I was still having the same problem! :cry: So now I think it may be a faulty alternator or the regulator because they both came together and from the same company? Know of any easy way i can test everything out that would possibly the source to this problem?
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top