Isuzu SUV Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
I know this thread is old but its good for the young bucks to know and Im one of them. I heared that its common to lose half to 1 quart every 1000 mile for 98-up rodeo's is it true! Not from burning oil or oil leaks If its true/or not post your comments and let us know cause my rodeo lose about a quart every 1000 miles, no leaks does not burn oil nothing let us know on you opinion. :D
 

·
Registered
Joined
·
3,933 Posts
Your Rodeo IS burning oil and it is a common thing to have happen. I only wish my Rodeo burned as little as a quart/ 1000 miles. I rebuilt my lower end but neglected to seat the rings properly.

It is common on these engines for the oil control rings to stick and the drain back holes in the pistons to get gunked up. This could have been avoided with proper maintenance from the beginning. The oil pushes past the compression rings and is burned in the combustion chamber. It doesn't just disappear into no where.
 

·
Registered
Joined
·
6,859 Posts
Mine's a user too! I check the oil frequently, usually with fill ups. I'd say that I have to add a quart every 2-3 thousand miles.
 

·
Registered
Joined
·
91 Posts
our original 99 Amigo used all kinds of oil....probably upto 1 qt per 7-800 miles

Our 01 Rodeo Sport uses a little but nowhere near that. Maybe a qt per 2000
 

·
Registered
Joined
·
4,001 Posts
When I used regular Castrol oil I was at 1 quart per 800.
I switched to Rotella T6 and now its around 1 quart per 2.5k miles.
 
1 - 5 of 5 Posts
Top