Isuzu SUV Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
80 Posts
Discussion Starter · #1 ·
ok So a year ago we bought an 88 2.6 and now we are having big problems with the motor. I need help guys before I shed out more than the $500 we already have. The engine has a knocking sound that sounds as though it's coming from behind the timing cover. It gets faster as the engine revs but doesn't get louder. The bottom pulley also has a wobble to it. It's not too much but enough that I noticed. The steering pump is now going too. (bottom pulley maybe?) Also. When you start it, unless you hold your foot flat to the gas, it will run for a couple of seconds then die. IF you hold your foot on the gas, most of the time it will carry on running. When this happens and it dies, the ignition lights stay on. When it's going fine they are off. Our local import specialist had no idea and charged $60 for knowing what I already knew. We have bought a new alternator and are going to fit it when we do the steering pump. (This weekend) And last but not least, the brakes. hehehe The rear drivers parking brake locks on if you leave the cable attached. I have tired a new cable and left it at it's lowest adjustment and it's still doing it. Any ideas?? I can't find a single problem with it.
Here's hoping that you will be able to help.
A very frustrated Cris. :?
 

· Registered
Joined
·
80 Posts
Discussion Starter · #2 ·
So a small update. I have the engine pretty much stripped in the bay and discovered that the key which locks the bottom pulley together has broken down. I don't know if this is a problem with these motors or not but I'm sure it's something to look out for. I potentially saved a great deal of cash by listening to the motor with a screwdriver. Old trick but has never let me down.

Cris
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top