Isuzu SUV Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
So did i. but i just bought this trooper a week ago and the check engine light comes on after a few minutes of driving it. The speedo didnt work when i got it and i did some research and check the ecm codes and sure enough it gave me a bad speed sensor which would explain the speed o not working. And if it was a mechanical speedo then i would not get a check engine light from it. I traced the wiring diagram from the manual and sure enough it said Speed Sensor. so do ya got one?? :wink:
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
No mislabeling here. The speed o doesnt work and that is the only code i pull from the ecm. it is a 90 trooper 5 speed v6. Go to your parts store and ask for a speedo cable for that car and see what they tell you. There is not one. The speed sensor is 168 at autozone. Now i am not saying that i had abs but you do not need abs to have a speed sensor.
 

·
Premium Member
Joined
·
5,577 Posts
I understand that you don't need ABS to have a speed sensor, but I was under the impression that the first Trooper with any kind of speed sensor was the 1992 Trooper. I could very well be wrong. Call Merlin at St Charles www.planetisuzoo.com/dealers.htm and see if he can get you a better price.

-Tad
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #7 ·
well i owe you a BIG your right. I was changing the diff. oil and tranny oil and rear end oil and was looking around and found the speed o cable attached and unplugged it nd sure enough it was broke. I dont know here that dad gum speed sensor would go or control for that matter. Unless its for the cruise?
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top