Isuzu SUV Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
392 Posts
Discussion Starter · #1 ·
on my trooper, 2.6 FI 4ze1, ill crank it. 5 seconds later it stumbles and dies. however, once its warmed up, it's fine. i usually have to rev it for a few seconds before i can drive it (otherwise it'll just die when i put it in gear) before i start driving. any ideas? i thought it was the fuel filter, but i changed it and its still acting up. ive heard about the idle air valve sticking and causing this, but i cant find a picture to identify it.. i think its bolted to the bottom of the intake. vacuum hoses are all new, triple checked and they are in the right place.
 

·
Registered
Joined
·
10,560 Posts
Find the big rubber hose on the throttle body. It's on the firewall side coming from underneath. Pull it off the throttle body and spray a good shot of PB blaster or seafoam down the hose and reattach it. Let it sit overnight. If the idle air control is sticking it should work better in the morning when you start it.
 

·
Registered
Joined
·
392 Posts
Discussion Starter · #3 ·
found it, its got some cracks. i will pick up some seafoam tomorrow and try this. found the iac, a pain in the *** to get to, i was gonna pull it out and clean it but ill try this first.
 

·
Registered
Joined
·
392 Posts
Discussion Starter · #4 ·
well i managed to pull the sucker off without removing the manifold; loaded it with PB blaster, let it soak for 30 minutes, cleaned it out, put the lines back on and i put electrical tape around the cracks as a temporary fix. started up and idled right below 1000rpm. hopefully it stays that way!
 
1 - 4 of 4 Posts
Top