Isuzu SUV Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
823 Posts
Discussion Starter · #1 ·
Last night, after a late night recovery of a truck, driving home, the troop lost ALL power, would not accelerate, or maintain speed. It was acting like a Holley with a bad power valve adn accelerator pump, complete with a miss fire( I am pretty sure about that now)..

Anyway, pulled into a gas station, looked under the hood for loose wires etc... everything visually checked out.., so I tryied to leave, and not 50 yeards out of the station, the check trans, adn engine lights flash, and the troop STOPS DEAD....okay, I oput it into reverse, and backed back in tot he gas station, at which point it stalled... :evil: , you know how damn heavy this thing isall by your self(well, I had the wife wiht me, but those that have met her, know that she cantoffer much in the way of muslce, so she didnt)...

Anyway, after a few minutes, I decide to turn it over, and bingo, just like nothing was ever wrong... I drove it around the station af ew times, trying to see if ti would do it again, or get me home... I drove home with out further incident... and again today.... no codes.. nothing...No I didnt reset the ECM yet... but still, this is right at the top of my weird sh%T-o-meter...and its bothering me..as I havea 500mile drive in a couple of days..

BTW, all reading were normal through all this...

Any ideas??

Chase
 

·
Registered
Joined
·
823 Posts
Discussion Starter · #3 ·
Stereo? it supposed to have one..LOL... I put a set of Hellas on it a few weeks ago, and havent ahd any issues. They werent even on when it happened, I had already looked into that...

I am thinking that the alt might have gotten a little wet, BUT, this a while before that happened...
Again, dunno, it hasnt happened since... still weird though

Chase
 

·
Registered
Joined
·
166 Posts
Chase,

Don't know if I can be much help since nothing like this has happened to me before, but from reading a whole lot of posts with strange unrepeatable symptoms, most have reported back that the alternator was the cause. Normally alternators that are well-kept last a LONG time, as you probably know already, but from the frequency I've read of the strange problems with erratic engine symptoms and dummy lights coming on unexpectedly, I'd start by having the alternator tested. Plus it's an electrical more than a mechanical part and we all know how those nasty electrical gremlins start to act up unexpectedly at random times. Your knowledge of Isuzus greatly surpasses my own, but I thought I'd pass on the suggestion.

Rob
 

·
Registered
Joined
·
823 Posts
Discussion Starter · #7 ·
Yeah, I was thinking about it, it still "appears" to be putting out adequet voltage...but< yeah, I need to get it checked....today...

And warranty...is that gona be in the receipts in the truck? If so, I might just swap itout real quick...

I keep thinking about it....

Chase
 

·
Registered
Joined
·
7,208 Posts
You really shouldn't need a reciept considering it's got a lifetime warr. They should be able to recognize it's theirs. Ask me how I know this. :roll: I can never find reciepts unless they are from past vehicles that I don't have anymore.
 

·
Registered
Joined
·
141 Posts
chase,

should be in the big pile of receipts.

if not I can dig up credit card records to help ya.

ALSO I'm not sure if a battery can fubar an alternator, but that battery is suspect and I'd switch it out post-haste mi amigo.
 

·
Registered
Joined
·
823 Posts
Discussion Starter · #10 ·
Yeah, I REALLY want to replace that battery, but everytime I have time to get to it, its like 11pm.....

And the damn optima is about 100 buck...that I dont have at the moment....

BUt, yeah, I keep thinking about this... SO, it might just have to get me home...I am alrady being delayed another day...to finish theis damn house...

I dunno, hopefully it will would out.....

Chase
 

·
Registered
Joined
·
30 Posts
chasespeed said:
Yeah, I REALLY want to replace that battery, but everytime I have time to get to it, its like 11pm.....

And the damn optima is about 100 buck...that I dont have at the moment....

BUt, yeah, I keep thinking about this... SO, it might just have to get me home...I am alrady being delayed another day...to finish theis damn house...

I dunno, hopefully it will would out.....

Chase
Check the retart relay, particularly if the heater fan goes off when the problem occurs, if it isn't that, then I'd guess the alternator output to the restart relay. When the restart relay fails to operate properly, either due to a defective relay or the lack of an alternator output to energize same, the vehicle goes into a limp mode.

Been there before, mine turned out to be the alternator, however, I did change the restart relay as a precaution.

All this info is in the full Trooper workshop manual and it's supplement.
 

·
Registered
Joined
·
823 Posts
Discussion Starter · #12 ·
Do you mean the restart relay?

And as far as a helm manual ,Ihavent gotten that far yet... where is the restart relay.. I wont see this till I get back to VA, leaving around 6 am local, adn I am gonna pull my spare battery, untill I can get an Optima.. and have the alt checked at the parts store, and Remove replace as needed...

Anyway, if it will just get me home...... I will be good to go, as I have nothing here...all at the shop...

CHase
 

·
Registered
Joined
·
30 Posts
chasespeed said:
Do you mean the restart relay?

And as far as a helm manual ,Ihavent gotten that far yet... where is the restart relay.. I wont see this till I get back to VA, leaving around 6 am local, adn I am gonna pull my spare battery, untill I can get an Optima.. and have the alt checked at the parts store, and Remove replace as needed...

Anyway, if it will just get me home...... I will be good to go, as I have nothing here...all at the shop...

CHase
Typo on my part, it should have read restart relay. It's under the hood on the passenger side. They are all well marked on the lid of the enclosure, it should be X17.

The relays are only a few bucks and a generic version is available from almost any store, just take your's in and they'll match it.
 

·
Registered
Joined
·
823 Posts
Discussion Starter · #14 ·
K2, thanx for the info...

Well, I got down to VA, without incident..so...

Anyway, now that I am down here, I can look into things ALOT more thoroughly, since I have access to the shop and all now.....

Thanx..

Chase
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top