Isuzu SUV Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I'm trying to do the timing belt, water pump, on my moms 99 trooper with the 3.5. I can't find any manuals on the trooper for this year to help me. I saw the write up in the forum about the 3.2 timing belt instalation, is it the same for the 3.5?
Is there any special tools need for the job?
What are the torque specs I need to know to do everything?
What other parts should I replace while i have it tore down?
Is their a manual out there on this car?
The videos that were in the 3.2 write up, do they apply to the 3.5?
Is the pully for the cooling fan prone to fail? her's seems to be making a lot of noise,

Please any help or direction would be great

Thanks in advance

Jon
 

·
Registered
Joined
·
1,623 Posts
That's the classic reference OBC has given you and is the best I have seen for how to set the timing.

If you want the shop manual though give me a PM and will get it on my FTP site.
 

·
Registered
Joined
·
1,343 Posts
the 1st one i did i used the factory manual , i did it 5 times before i found the factory manual was wrong on setting drivers side cam gear,

just use the above link that airhead rider posted and you will have no problem , its great.
 

·
Registered
Joined
·
3,977 Posts
When you do replace the belt it's best to ASSUME that the timing is lost, that way you are sure to get it right the first time. Use the second Isuzu Tech video in the above shortcut:

This vid is for changing the belt when the timing has been lost.
5:39 and 11.9 mb-
http://www.drivehq.com/file/df.aspx/pub ... iming2.wmv
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
This is actually my first time diving into an import vehicale.

I know the timing is correct on this trooper because I haven't torn it apart yet. I'm only wanting to do it because it has 96,000 on the ticker and the manual says to change it at 75,000. So I was wanting to preform a little preventitive maintanice on it. The other day when she was driving it she lost all the power to it and it died on her pulling into her work. I was following her at the time it happend and stoped to help her, it started right back up with out issue, expect for a strange noise comming from the fan on the motor. I thought it was the water pump, not knowing that the water pump was actually behined the cover and part of the timing belt system. Then she was going to work again on monday, and as soon as she pulled out of the driveway it died again, but this time there was smoke that came out of the engine compartment. I was not their to witness this when it happend again. I assumed it was the altenator or a stuck pulley causing the belt to burn a little. I had her bring it to my house and this is were i'm at now.
 
1 - 8 of 8 Posts
Top