Isuzu SUV Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Just wanted to post a positive message! I've been driving with this horrible drivetrain tick for about 30k now. Well I put some engine cleaner through it the other day and changed the oil and filter (2 days in a row) and the tick went away!!!! woo hoo!! This thing has 200k on it and it runs like a top. I love my trooper. btw, I had tried this before with seafoam, mmo, chemtool,.... just to name a few but to no avail. this time it worked. I'm running 10w30 dino oil and a wix filter. Anyway I just can't believe it. If this has happened to anyone else I would love to hear about it.
 

·
Registered
Joined
·
1,624 Posts
I fixed it on two 95s I had (both over 200k at that time) using a jug of Seafoam in the crankcase. Never put the truck in gear but just revved it from idle to ~ 2k for about 10 minutes, In both cases 10 min was about 5 min after the tick had stopped.

Both went 10s of thousands more miles after that on Rotella 5w-40 after that.

For sure the problem can be wear but more often seems to be gunked up lifters.
 

·
Registered
Joined
·
50 Posts
zadok2k said:
Just wanted to post a positive message! I've been driving with this horrible drivetrain tick for about 30k now. Well I put some engine cleaner through it the other day and changed the oil and filter (2 days in a row) and the tick went away!!!!
What engine cleaner?
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top