Isuzu SUV Forum banner
1 - 20 of 86 Posts

·
Registered
Joined
·
2,707 Posts
Discussion Starter · #1 ·
I have found that my project rig is going to take even more resources then my latest est (I love working on it, but I need a driver now!). So I went on a hunt for a $1k turn-key beater, didn't need to be a Zu (but was aiming for one). Just needed to be a 5spd & street legal. Well money for an interim drivable rig came short, only about $500. :shock: How am I going to get a Zu for $500 that runs?! Great, now I'm going to end up with an 83 Honda that smokes & stalls & won't pass emissions testing...

Enter: The Grey Ghost!

>>>(will add pics tomorrow)<<<

I had all but given up on finding a rig of any kind, when one of my phone apps alerted. (craigsnotifica for android) New search results for your search "Isuzu". I think "ok whats out there that I can't afford now?"

Answer: Top result is a post less then 2hrs old = ISUZU Trooper - $500 obo ... Ok I'm interested, lets open this ad. '92 Trooper (grey) currently not running (needed a jump this morning), approx 150k body/int decent, manual transmission, rig needs mechanical tlc...

I email the lady & we go back'n'forth a few emails. She says one guy offered her $450 & will be out this afternoon @ 2pm, I say thats too bad cuz I would probly have brought her full $500 asking price blind if the battery was the only thing keeping it from running. She says come take a look & we'll talk.

I get there early & start poking around... Its side-swiped something on the passenger side (look free trail damage! lol), the passenger auto hub has grenaded & the CV is sitting loose in the hole, retracted by the inner boot (all boots intact! bonus). Its a Cali car so no frame rot, solid rocker/kicker panels (other then the sideswiping), dry rotted tires, expired '09 Cali tags :!: How has this woman not gotten pulled over in 2yrs?.

She comes out & answers a few questions, says she has NEVER used 4x4 in the 5yrs shes had it, so no telling how long the hub has been toasted. Also it stopped idling right about 8mo ago so you have to 3-foot-it or it stalls. She then informs me that she doesn't feel right letting me buy it out from under the $450 guy (he was first after all), I said "I understand, but please tell him about the blown hub. It could be dangerous to anyone who doesn't know & tries to use 4x4" She agrees & I go home. The other guy lowers his offer at news of the hub & she gives me a 2nd round... We settle on $450 from me & I drive it home (that was exciting! 5mi inner city residential, lots of stop signs).

Now that its home, time for an in-depth look at whats wrong & what I just got myself into lol.

The bad:
Check-Engine-Light = ON
Speedometer/odometer not working
Stock Isuzu tape deck & only the drivers door speakers(blown) are hooked up
Passenger side body damage
Doesn't Idle
Drivers door hinge popped the tac-welds
Dry rotted tires
Poor/Dirty grounds EVERYWHERE
Heater core has been by-passed (hoping it was a bad hose not a bad core)
A/C Doesn't seem to work (possibly related to bad grounds)
Drivers seat pretty torn up
All fluids (other then brake fluid) DANGEROUSLY LOW

So, I have bought myself a limping Trooper. Lets see what kind of medic I really am & how bad off my latest patient really is.

Found receipt for last oil change = July '10 :shock: Oil smear on dip-stick... ok change oil NOW. Run out to wal-mart & grabbed all fluids; pwr steering, dot4 brake/clutch, jug'o'green coolant, 10qts of cheap 10w-30 & two fram filters (they didn't carry my brand so fram will do for 1500-2000mi flush changes). Wrenched around the battery terminal cables & hoped for the best, fired it up & grabbed a can of carb cleaner to look for vac leaks (nice trick Tony). Low & Behold with a full belly of oil it IDLES on its own!!! Not a single vac leak either!

Well tomorrow brings some wiring cleaning, a photo shoot, maybe an EGR cleaning & more test driving. This one gets NO MODS, until the '89 lives.

~psguardian
 

·
Registered
Joined
·
4,823 Posts
:wav:

show some pics,this is kinda like what i did 2 weeks ago...needed a DD so my trooper found me and I rescued her.
 

·
Registered
Joined
·
2,377 Posts
More Troopers !!! :eek:ccasion5:
 

·
Registered
Joined
·
2,442 Posts
Still waiting for pics, minus the roof racks though ;-) ;-)
 

·
Registered
Joined
·
2,442 Posts




Sorry, couldn't wait ;-)
 

·
Registered
Joined
·
2,442 Posts
Well, it doesn't sound as bad as I thought... Couldn't really hear it on the phone very well, unfortunately. Either way, the gages don't seen TOO far off, I'm pretty sure the charge drop when you stomp it is normal. I still think you should check the grounds in the dash. If the tranny is good on that thing, I say you still got a good deal, just drive it until (if) the engine dies. I know someone with a DOHC that could be swapped in there ;-)
 

·
Registered
Joined
·
4,823 Posts
psguardian said:
I need to find the grounds under the dash first... And some tires (those weather checked things scare me).

~psguardian
take off kick panel on drivers side front floor,there are a couple there,it's held in by 3 plastic clip things
 

·
Registered
Joined
·
2,707 Posts
Discussion Starter · #15 ·
I'm hoping not, but I think it's either a rod bearing/wrist pin, horribly stuck lifters, ping/knock from being out of tune.

This thing has gone 10 mo one it's last oil change, with no oil added to top it off in that time.

I'm going to take another vid of me revving it slowly, quickly, & then fluttering in the 3-4k rpm range (where I notice the 'noise' most). Then y'all can weigh in on the possibilities.

~psguardian
 

·
Registered
Joined
·
2,995 Posts
Hey, it runs! I would stick some seafoam before the next oil change and see what happens. I don't have an opinion on the engine, just could not hear well enough. I just paid 350 for an 89 LS Pup in LaGrande a month ago and it runs but has no compression in 2 cylinders. It will be awhile before it runs again.
 

·
Registered
Joined
·
2,995 Posts
I am thinking upper valve train, I have heard putting a small amount of ATF will free up sticky lifters, you might look into that.
 

·
Registered
Joined
·
2,707 Posts
Discussion Starter · #19 ·
Yea I have done strait ATF flushes & seen strait Diesel flushes. After an emissions test I'm going to do a few oil changes with marvel mystery oil in the crank & the tank.

On a more pressing note, I found out why she's running soo sickly! 60A alt in a rig designed for a 75A (my rig has A/C). Today I tried to drive up to do all the DMV & emissions testing, CEL came back & at idle ALL of the idiot lights came on. Had it bench tested & its putting out almost nothing. Yay me lol. I've got a line on another though, all will be well. Just a matter of time lol.

~psguardian
 

·
Registered
Joined
·
2,995 Posts
So have you been able to get the alt problem fixed? I brought the spacecab home this weekend. Picked up an slightly used AMC head with Delta cam and a header along with some other goodies for a fantastic deal from another member. So I am getting closer to getting my hands in there.
 
1 - 20 of 86 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top