Isuzu SUV Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
6,257 Posts
Discussion Starter · #1 ·
and oh my god is this engine not running right! It has nooo power. Any ideas what the problem could be? Right now I have the o2 sensors disconnected so that I know it's not some sort of issue with the computer trying to tune the mixture, rather it's just using the open loop which should make the engine run decent though gas use would be high.

On idle you rev it, it's just fine, meaning it will smoothly go up and down. if you put it in drive though, this thing has no power, and doesn't want to go anywhere very difficult to get it to even go up to 3k. It does better with low rpms though. Any ideas what the issue is?
 

·
Registered
Joined
·
1,204 Posts
What I always do when fixing a vehicle is fix the known issues before moving on to the unknown issues. Fix the o2's first
 

·
Registered
Joined
·
157 Posts
it could be a myriad of things...

Does it feel like it's stumbling if you step on the gas? it could be a back pressure issue, like a plugged catalytic converter or muffler.

It could also be fuel or a timing issue. (changed a fuel filter in recent memory?) Have you done any work to it recently or anything or is this a new random issue?
 

·
Registered
Joined
·
6,257 Posts
Discussion Starter · #5 ·
It's a new engine I put in that I'm trying to trouble shoot.

If u gas it it stumbles all the way.

I think the O2 sensors are getting more attention than they need. The lack of O2 sensors would not make a car almost not be able to run. The ecu will throw codes and use the premapped fuel ratio. You'll use more gas but the engine will still run fine.

I got a new maf, I suspect a lean mix. The engine was giving a lot of heat off and warmed up really quick, too quick to be honest. I recall from memory that lean mixes run hot hence why they're dangerous. Hopefully an obd scan could tell me some worthy info.
 

·
Registered
Joined
·
6,859 Posts
Sounds like the timing is off.

When you set the timing, did you set the marks right? If one bank wasn't sprung, it'll run like that. Trust me, I know......

Sounds like your in the home stretch, don't give up now!
 

·
Registered
Joined
·
6,257 Posts
Discussion Starter · #7 ·
It was the throttle body.
 

·
Registered
Joined
·
8,605 Posts
Care to elaborate?
 

·
Registered
Joined
·
6,257 Posts
Discussion Starter · #9 ·
I bought aOBD reader and pulled the codes. I didnt want to waste time especially how on memorial day there is an event here. I had 7 codes. 4 of which were O2 sensors, so it came down to 3 legit ones. EGR, TPS, and cylinder 6 misfire. I looked at the EGR and realized I hadn't connected the plug. I did, and started the car. Still the same issue. I concider replacing the TPS but remember that I had issues getting it to idle and that I had adjust the preload on the throttle valve. I took all the preload off, but put just enough so that the valve doesnt stick. Restart and everything was suddenly working better. I havn't dont much driving, but on tuesday I'll find out. I did my test by jacking the rear axle, and by putting it in drive while in 2wd and for that 2 mins the engine would pick up fine and would not hesitate to go past 2k.
 

·
Registered
Joined
·
8,605 Posts
That's not much of a test though, no load on the engine really. Let us know how well it does with all 4 on the ground. I hope you figured it out, oh, and I know from personal experience that sometimes a car will run like total crap when an O2 goes out. Not quite what your talking about but some of the older EFI cars would run like dogs when the O2 went bad.
 

·
Registered
Joined
·
6,257 Posts
Discussion Starter · #11 ·
but wouldnt that simply be because the computer would still use the data the O2 sensors gave it to run the engine?
 

·
Registered
Joined
·
8,605 Posts
or dump too much fuel
 

·
Registered
Joined
·
2,387 Posts
Remind me why you have the o2 sensors disconnected???
 

·
Registered
Joined
·
8,605 Posts
He doesn't have bungs for them yet, he's gonna get those in and hook them up and see if it fixes it
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top