Isuzu SUV Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hi,

I have a serious problem with my trooper 1986 with 5 speed gear and 4ZE1 2.6L as the following:

1- It is very difficult to start it, and when start the RPM will goes down until die.
2- The difficulty in starting not only in the morning but all the day time.
3- Even when start, when moving, sometimes the RPM will be high but without speed and some time it goes down until die, and sometimes it goes good after the RPM 3000, and alternate between these.
I need your help guys.

Alhersh
 

·
Registered
Joined
·
1,343 Posts
i had one and it was back firing thru the exhaust and intake , checked out everything , everthing checked ok , the problem was the dist cap was arcking across inside the cap to different cylinders , changed the cap , fixed it.

your problem sounds like a fuel problem. rebuild the carb. check fuel pump .
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
@ 5 th rodeo
Thanks alot for the information,

The carb has been rebuilt before 1 week and the fuel pump works fine, some one told me that it maybe the Air flow sensor!!! but how I can know that this sensor is working OK or is has a malfunctioning problem.

Alhersh
 

·
Registered
Joined
·
523 Posts
Well, not sure, but my 86 Trooper is a 2.3l and is carbureted....so I believe there is no air flow sensor on a carbed motor (could be wrong).

I'd try the basics, like distributor cap and rotor, plug wires, fuel filter, etc. Sounds like it might be a cheap easy fix.

Mine was difficult to start and backfired when I bought it. I swapped fuel filter, dist cap and rotor, plugs with no results. Finally swapped the plug wires....and when I pulled them I noticed mice/rats had chewed away the insulation on the bottom of the wires. New wires, and she purrs along.
 

·
Registered
Joined
·
1,343 Posts
i would do what sammy said , then check the egr valve , just remove it and give it a good cleaning , check all vacuum hoses also.

was the problem there before you rebuilt the carb , i put a weber 32/36 on mine and it ran so much better , you can get them on ebay pretty cheap.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 ·
@ 5th rodeo & sammy, thanks alot for the suggestions,

The problem happened after I have rebuilt the carb, it started as I have mentioned above, and now; it couldn’t start even. It comes to be started and immediately it dies. Today I have changed the dist cab and still cannot be started and produces a backfire.

Alhersh
 

·
Registered
Joined
·
1,041 Posts
could be worse, he could have a pic in his signature :eek:
 

·
Registered
Joined
·
7,284 Posts
pmat said:
could be worse, he could have a pic in his signature :eek:
That pic would be great in his sig !

Kinda big as an avatar, though.

:D :D
 

·
Registered
Joined
·
2,442 Posts
JoeIsuzu said:
Your user avatar is OBNOXIOUS.

Jack
Other than being a big large, I kind of like it :)
 

·
Registered
Joined
·
13,615 Posts
Maybe just maybe the float is flouding and spilling gas all over to crank it and then look down the carb to see if fuel is spilling or ton's of fumes. But always go easy first cap and rotor plugs wires etc... I had the screw fall out of the rotor on the first test drive of one of my amigo's 2.6 needless to say my neighbor towed me the mile back to my house.
 

·
Registered
Joined
·
1,343 Posts
it really sounds like a carb problem , like i said i changed mine to a weber 32/36 , i forget the letters but i will try and fine out , something like dgev.

it is one of the best thing you can do , i also bought the jetting kit. like stated above it sounds like a floot level problem , or a vacuum hose hooked to the wrong place , or a bad gasket in carb.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #13 ·
@ JoeIsuzu & pmat & Selador AKA Tat & Mediamonkey11

Thanks for your comments on the avatar pic :D, I removed it.

@5 th rodeo & bradzuzu

Today I pulled out the dist and changed the round seal on it and return it back, and I have adjusted the timing belt to the new direction of the dist and its running now my lovely trooper.

Thanks all for your comments and suggestions,

I really appreciate that
 

·
Registered
Joined
·
7,284 Posts
alhersh said:
@ JoeIsuzu & pmat & Selador AKA Tat & Mediamonkey11

Thanks for your comments on the avatar pic :D, I removed it.

@5 th rodeo & bradzuzu

Today I pulled out the dist and changed the round seal on it and return it back, and I have adjusted the timing belt to the new direction of the dist and its running now my lovely trooper.

Thanks all for your comments and suggestions,

I really appreciate that
I liked the pic.

Put it in your sig. :D

Glad you got the problem fixed.
 

·
Registered
Joined
·
7,284 Posts
alhersh said:
@ Selador AKA Tat,

How can I put it to my sig :?:

Thanks
Go to the top of the page, and hit that "Profile" link.

In there, you'll find the box to input your sig.

All you need to do is to use the exact same link that you used to make it your avatar.
 

·
Registered
Joined
·
7,284 Posts
alhersh said:
@ Selador AKA Tat,

I did it, I am testing it :D
You found where to input the link. That is half the battle.

:D :D :D

Now you need to put the image tags around it.

Copy the following, and paste it into your signature.

Code:
[img]http://redtools.net/wp-content/uploads/2011/04/Craftsman-540pc-mechanics-tool-set.jpg[/img]
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #19 ·
@ Selador AKA Tat,

OH, I really appreciate that for you, very nice
:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D
what do you think about this pic?
 

·
Registered
Joined
·
7,284 Posts
alhersh said:
@ Selador AKA Tat,

OH, I really appreciate that for you, very nice
:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D
what do you think about this pic?
Glad you got that worked out.

Pic is kinda big. Bigger than it was in your avatar, no ?

You could eliminate a bunch of the blank white space, and make the pic smaller as well.

Kinda like this.



By the way, It is usually helpful if you indicate where you live. (It's in your profile, and will show up under your avatar.)

And to put the information about your rig, in your signature as well. Year, model, engine, trans. Etc...

:D
 
1 - 20 of 23 Posts
Top