Isuzu SUV Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Okay, on my '01 passport, I have got coolant dripping off of the skid plate onto the ground. Not vast amounts, but little drips every 10-15 seconds. I've lost half my overflow reservior, and I can't pinpoint the source of the leak. Anyone have any ideas?:roll: the thing has 54k on it, so I don't THINK its the water pump :?, but I guess stranger things have happened. I can't check the hoses right now as they are hot after just being driven, and its snowing out and I'm not so sure I want to go back out there today. So, any things I should check before blaming the water pump? aside from hoses? the radiator looks good to me, but I don't know if it has a crack somewhere in the lower tank or something. Any help would be greatly appreciated. here are the vehicle specifics again: '01 Passport EX-L, 3.2v6, 4wd, automatic.
 

·
Registered
Joined
·
166 Posts
My best suggestion would be to first of all remove the skidplate. Next park the vehicle on some fresh snow see what is exactly above what's leaking. You should be able tell if it's the radiator, a hose, or the pump. I would think a water pump and radiator would last longer than 54k, so I would start simple and check for loose hose clamps and worn hoses first, then look for the more expensive fixes. Good luck.

Also you can take a shop towel and wipe down the reservoir, the bottom of the radiator, and other areas with coolant on them. Then trace it back once the coolant reappears.

Rob
 

·
Registered
Joined
·
454 Posts
I see you also posted this on the 4x4 site.

Been there. It may not be your water pump.

Check the threat at the 4x4 site. I responded to your question over there.
 
1 - 3 of 3 Posts
Top