Isuzu SUV Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
Okay, Ive ruled out the started and the ignition so Im down to this little beast. I've searched the boards and cant find much on the Neutral Safety Switch (N.S.S.) that helps me. I need to know the following

1) What side of the transmission is the N.S.S. located. Passenger of Driver?
2) Can I access the N.S.S. from the interior of the vehicle or do I have go under?
3) Is this fairly easy to replace?

Thanks

Scott
 

·
Registered
Joined
·
11,705 Posts
http://www.myisuzuparts.com shows 2 brands of a/t. Anyhow, plug this part number 8-94364-923-0 in the upper left window, click submit and observe the pic (item #50).
 

·
Registered
Joined
·
3,980 Posts
I'm not familiar with the V-6 tranny but on my Aisin, the switch is on the passenger side. I had issues with mine. Sometimes it cranked fine and sometimes I'd have to push the tranny selector forward to crank it. Then..................one day it just didn't crank. I just pulled the switch off, took it apart, cleaned it with solvent, and took some emory cloth and shined up the contact surfaces. If your switch is like mine, be careful when you disassemble the switch as the blades on the part that swings are spring loaded and will pop out and they are very hard to find when you accidentally drop them in the yard!!! (I know from experience) Luckily I had another trooper that I was robbing parts off of and I took what I needed out of that switch. After cleaning and polishing the surfaces, put some dielectric grease on it and reassemble.

ernie
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #4 ·
guys

thanks for the help. ill give it a try today. i have the thick !wo manuals, and the switch is hardly mentioned
 

·
Registered
Joined
·
11,705 Posts
Unless it has some type of mystical tamper proof circuitry, you should be able to, 1, just disconnect it or, 2, jumper the wires and bypass. Just remember it'll then crank in gear (I reckon') which would be kind of weird with an auto.
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #6 ·
Well, I got the switch off! It was a Bear since I basically did it by crawling under the vehicle. Took me awhile to take it off. Ive got to get one of those lifts or find a rent a lift place here in Houston.I cleaned up the switch and brushed the contacts. moved the switch to replicate neutral and park but still no start. Finally removed it from the transmission and unplugged the connection in the engine compartment, still no No start, no way. Guess Ill just have to wait till the new one arrives. All my engine lights come when I put in the key,radio etc. Battery still has power. Couldn't be the ignition switch? I tried to pull that off yesterday but there are no bolts or screws to remove it. Anti - THeft?
 

·
Registered
Joined
·
11,705 Posts
msc_8791 said:
Okay, Ive ruled out the started and the ignition so Im down to this little beast. I've searched the boards and cant find much on the Neutral Safety Switch (N.S.S.) that helps me. I need to know the following

1) What side of the transmission is the N.S.S. located. Passenger of Driver?
2) Can I access the N.S.S. from the interior of the vehicle or do I have go under?
3) Is this fairly easy to replace?

Thanks

Scott
Why don't you start from the beginning?

1. What seems to be the problem?
2. When did it begin?
3. Was all well prior to problem?
4. What have you checked and how did you check in pursuit of a remedy?
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #8 ·
Problems started out of the blue about three to four weeks ago. Truck wouldn't start, So I switched it to neutral and it immediately started with no hesitation.
Next time I stopped, it wouldn't start again , I jiggled the shift stick between Park and Neutral, put it back in park and it started again.
Went to Denny's and it took me about 10 minutes of shifting between P & N before it Finally started in N.
Went back to where I store the vehicle, came back in a week and couldn't get it to start at all, When I turn the key, all lights come on, have brights lights on so its not the battery.
Neutral Safety switch is out of truck and disconnected from harness at present. I guess what got me started down this path was that I could get it to start after shifting through the gears.

MAybe I should check the solenoid, but Im not sure how to do it even though I do have a voltmeter. Heck I don't even know where the started is.
 

·
Registered
Joined
·
11,705 Posts
I'm wondering if your tranny has the range/mode sensor which might play a role in this. Just a shot in the dark. Do a quick search against that and see what you find. I know if it's faulty or dirty that will result in poor to no shifting. It might also tell the starting circuit you are not in park or neutral though I don't know that to be true.
 
  • Like
Reactions: MADISUZOO
1 - 9 of 9 Posts
Top