Isuzu SUV Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
i have a 1988 isuzu trooper 4 cylinder 2.6 4EZ1 ... he starts right up cold. but while driving he shuts off whenever he wants. and when i shut him off after driving he wont start back up. i just changed the head gasket. does this have anything to do with timing. or i heard something about a coil in the distributur. any help? thanks guys! :D
 

·
Registered
Joined
·
1,043 Posts
got an immobiliser?
 

·
Registered
Joined
·
1,343 Posts
i would check cylinder compression , i doubt if thats the problem , its good to keep the numbers , i would think its the fuel pump.or wiring making good contact to fuel pump or ign.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #4 ·
no immobiliser. thanks tho. so should i change that fuel pump? im a 23 year old girl.im doing this myself so i can learn just in case. the most help i can get the better. i have this truck pretty much all figured out because i had to replace most of it. i know its a no tolerence motor. so for it to drive for awhile before shutting off its not timing right? you saying about the fuel pump sounds right. but i also lost dash lights somewhere along the way. so if you think wiring is the problem then thats something im not sure about. but im sure your not talking about a simple fuse. its never that easy lol oh man :D
 

·
Registered
Joined
·
5,214 Posts
bobbie said:
no immobiliser. thanks tho. so should i change that fuel pump? im a 23 year old girl.im doing this myself so i can learn just in case. the most help i can get the better. i have this truck pretty much all figured out because i had to replace most of it. i know its a no tolerence motor. so for it to drive for awhile before shutting off its not timing right? you saying about the fuel pump sounds right. but i also lost dash lights somewhere along the way. so if you think wiring is the problem then thats something im not sure about. but im sure your not talking about a simple fuse. its never that easy lol oh man :D
BOBBIE , NEXT TIME IT SHUTS DOWN WITH THE KEY STILL IN THE ON POSITION CHECK TO SEE IF THE CHECK ENG LITE IS ON ,RED , IF THE RED LITE DOES NOT COME ON WHEN THE ENG DIES IT COULD BE JUST THE MAIN RELAY UNDER THE HOOD IT COULD BE JUST THE MAIN RELAY DIEING FROM THE HEAT, IF THE LITE IS ON WHEN THE ENG STOPS THEN IT COULD BE THE FUEL PUMP, , DIST OR THE IGN MODULE , IT IS GOIGN TO TAKE A BIT OF TESTIGN TO MAKE SURE THE FUEL PUMP IS EITHER DEAD OR JUST SOME BAD WIRING TO THE TANK WHICH IS VERY COMMON ON THESE TRUCKS BECAUSE OF AGE , THE PUMPS IF ORIGINAL DONT USUALLY DIE LIKE THAT , THEY EITHER RUN OR NOT , CHECK THE CONNECTOR BACK BY THE FRAME RAIL YOU CNA REACH IT THRU THE RT REAR WHEEL OPENING THERE IS A TWO WIRE CONNECTOR THAT IS NOTORIOUS FOR LOOSING CONNECTION THERE , JERRY
 

·
Registered
Joined
·
6,404 Posts
Does it sputter out or is it just like instant, "click!" OFF?
 

·
Registered
Joined
·
1,850 Posts
If it sputters then dies then maybe you have a plugged fuel filter or pump..sediment in your tank will settle at the bottom but once you start moving and the pump is pulling fuel after a litle time the junk builds up around the pump or in the filter and plugs it up then the truck will stumble like its starving for fuel and could stall...once it stalls and you stop all that junk floats back down to the bottom of the tank....???
Also check grounds..my trooper would run until I shut it off....then nothing..no cranking or dash lights...found the negative battery cable was just loose enough to cause this....I rigged it up to make good contact and problem went away....
 

·
Registered
Joined
·
6,404 Posts
ramzoom said:
If it sputters then dies then maybe you have a plugged fuel filter or pump..sediment in your tank will settle at the bottom but once you start moving and the pump is pulling fuel after a litle time the junk builds up around the pump or in the filter and plugs it up then the truck will stumble like its starving for fuel and could stall...once it stalls and you stop all that junk floats back down to the bottom of the tank....???
Also check grounds..my trooper would run until I shut it off....then nothing..no cranking or dash lights...found the negative battery cable was just loose enough to cause this....I rigged it up to make good contact and problem went away....
Yep, this is why I asked. Great minds and all :idea: Although, JLEMOND is the real guru here. :D
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #9 ·
oh man.. okay.. i bought the fuel pump. went out to put it on and tryed starting him up and nothing. when i turned the key he just cranked super hard. i hear the fuel pump click when i turn the key alittle. but before he was atleast starting. a bad fuel pump wouldnt make him crank like that right? is that a timing problem? im so afraid of ruining his motor. he cranks super hard. sounds painful. lol im so confused now. thanks for the help. yinz are awesome. i really appreciate it :D
 

·
Registered
Joined
·
31 Posts
sounds like a poor electrical connection somewhere. got anyone available who has some experience trouble shooting problems? sudden shut off might be an ignition problem, a little stumbling at times at it's random shut off would indicate gas delivery problem. When it quits or won't start, pull a plug wire, stick a metal something in it (screwdriver) and hold it about 1/8 inch from a metal engine part, then crank engine a couple turns and see if it sparks. (a helper is helpful) need to narrow the problem down to what system is causing it.
 
1 - 10 of 10 Posts
Top