Isuzu SUV Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all.. My 1st post here.. I've just bought a 88 trooper 4cyl. 2.6L 5spd 4x4. I've been learning a lot from reading through posts here and a few other forums. I really didn't know much about troopers (or cars at all for that matter) until getting this. So I have a few questions....

The idle will go up and down between about 1500 and 1000 rpms. But not always. There's a huge crack in the EGR hose that Im in the middle of replacing and the o2 sensor light is always on. So im also replacing the o2 sensor (and resetting the switch behind the odom)

1. Hoping this will fix the problem??

I've heard about the horrible cylinder heads on these models and hoping mine doesn't crack. Then the other day I start noticing steam coming from the tail pipe and its getting really hot (about 3/4 on the temp gauge) and losing water.. ugh.. I pull over and put some water in and tried putting some sealant in the radiator.. the steaming stopped and it hasnt gotten hot like that again.. yet. The temp gauge is staying at about the 1/4 level.

2. Should I just try replacing the head gasket or go for a whole new cylinder head? I've heard aluminumheads.com is a good place to get one?

Apparently my wheel bearings are shot.. I hear this clanking every time the front wheels hit any bumps. Thought it was the shocks but after checking them out, they were fine.

3. How much would it cost roughly to have my wheel bearings repacked? it seems a little beyond my abilities to do something like that.

4. Also what is the main reason for getting manual locking hubs rather than having the auto hubs?

This is just annoying and I don't know why it does this. Every time I unlock the drivers side door, all the locks are unlocked. So I have to run around the trooper and lock ever door every time I get out of the car. What's up with that?

5. Is there supposed to be a remote that comes with this model?

Thanks for any info!

-joe
 

·
Registered
Joined
·
35 Posts
Congrats on your new "old" truck. I have a 89 Trooper 2.6 and its been nothing but grief. :cry:

DO NOT EVER PUT COLD WATER INTO A HOT ENGINE! YOU COULD CRACK THE HEAD/BLOCK (I did this to a 1970 Impala 350chevy motor in FL when I was 16)

If your blowing steam dont drive it! Its the head gasket leaking into the cylinder, mine just had the same problem and I had it fixed under the warranty. If I were you I would go with a new head, I am not sure where you could get one but make sure it isnt a remanufactured old one or it might crack too, the one I have on my motor came with the "remanufactured" motor with a new head casting (supposedly its a new design by S&S Engines in Spokane<~~SUCKS!, WA - I bought the whole longblock for $1400 bucks when the bottom end went out on my old engine ~ it was the cheapest longblock I could find on the web and has a 70K/7yr warranty ~you will do better to go with a diffrent company~they will screw you on any warranty claim!!!! BEWARE!!!!)

UPDATE" DONT USE S&S Engines they will screw you on warranty & quality!!!

If the EGR "Pipe" is cracked you might be able to fix it with epoxy (JB Weld) But it its cheap enough I would get a new one, you dont want to slop any off that stuff into the pipe and restrict air flow. as I reacall replacing my plenum and throttle body was a complete pain in the butt, make sure you mark al of your vaccume lines with tags before you do anything to them - otherwise its a hose jigsaw puzzle.

I have had problems with loping in the past myself, I noticed when the O2 sensor is hooked up it will lope up and down to 2gran to 900 ~ but when I disconnect the O2 Sensor the loping completely stops. Yours could be loing from the EGR pipe being cracked too, If you havent replace your O2 sensor It is an easy swap, wait till the thing is cold and spray some rust bustr stuff on the pipe and let it soak in to ease the removal. If you tap on it with a small hammer LIGHTLY it will work the rust buster (PS something its called) into the threads for the thing and removal will be less likely to bang up your hands.

I dont know about the lock thing, Im assuming you have the power locks and whatnot, mine is all manual

As for the wheel bearings how many miles on the truck? If it is excessive I would replace them, do you hace aftermarket wheels? Check for the tightness of your dust covers, mine used to clank too but I noticed the covers were just loose. I would think bad bearings would squeal and not clank, and usualy its on one side that it can be heard. I dont think that both go bad at the same time.

well good luck, thats the best 2¢ I have right now

:roll: :lol: 8)
 

·
Registered
Joined
·
189 Posts
Howdy Joe,
Troopy had a great response, so there is not much for me to add. That anti-leak stuff is just a bandaid. I would not trust it to last too long, especially as it sounds like you have a cracked head. When you pull it off, most machine shops can check it for trueness, and for cracks. If it is cracked, do not bother having it welded, as it won't last. Go ahead and get the new head, with new valves, from the site you posted. I got mine from there, after my welded head cracked again. I have been happy with it. Also, go ahead and invest in an Isuzu headgasket. They aren't much more, and seem to be of better quality. Replacing the head is not a difficult job to do by yourself. Post back if you plan to do this, and I will give you a couple of shortcuts. The haynes manual tells you how to do it, but they make it way more complicated than it actually is.

Adam
 
1 - 4 of 4 Posts
Top