Isuzu SUV Forum banner
21 - 40 of 44 Posts

·
Registered
Joined
·
292 Posts
Discussion Starter · #22 ·
Well guys, not much of an update here.....but I did get my axle in yesterday. So, I thought that I would throw up a few pictures of the dropped diff installed. Also, I ended up replacing all of my ball joints, and flipped the UBJ in the process.

Flipped UBJ's:


Right diff bracket:


Left diff bracket:


Front axle shot:


Anyway, I'm heading back east to visit some family for the next few days, but when I return it should only be 2-3 days until she's running again (finally)! Once she's rolling again, here's what I have planned for the near future:

-fab some longer shackles
-add a leaf
-fab a tube brushbar/pushbar
-modify the Smittybuilt step bars for more ground clearance. OR just make some tubular rockrails.
-clean up and install the Yakima rack and gear basket that came with the truck
-Rhino-line everything below the trim line (from bumpers down)
-Clarion headunit and aftermarket speakers (from wife's old car)
-Build a box for two 8" subs and 225 watt amp
-plus more as I think of it......

Happy trails....
 

·
Registered
Joined
·
292 Posts
Discussion Starter · #23 ·
Great news! The Rodeo has been back on the road for the last 2 weeks, which really makes me happy since I was getting a little tired of taking the bus. :D Here's a little rundown of some of the things that I accomplished since the last post:

First, I guess I have to rant a bit about using big-brand autoparts store stuff. I know that countless guys on here have stories about getting burned by using non-OEM parts, so I guess I will add one more. One of the things that I had replaced during the top-end rebuild was the orings for the two coolant pipes. Figuring orings were not a major item, I chose to pick them up at my local parts store. So, I got the motor all buttoned up, got it up to operating temperature and ran it for around 30 mins. Around this time, I noticed a big ol' puddle of coolant collecting under the motor. After a bit of swearing and removing the intake again, I found that BOTH orings had failed. Learning my lesson, I got a hold of Jerry who sent me the OEM orings....and they are working just fine!

Another thing to mention, is that even after replacing all of the rocker assembly, I still had a noticable tick. It was not the constant clatter that I had before, though. This time, it sounded as if it were only one HLA that was stuck in thk #1 cynlinder bank. After about 150-200 miles though, the Rotella must have done its job and cleaned it out. The old 3.2 purrs like a kitten now, which makes me very happy. :D

The only other major work I have done as of late, has been modifying the front cross member to acommodate the diff drop. Here's a pic of the cutting that I had to do. I had to cut a straight section from the top half of the member, so that it would clear the diff housing. Then I cut a semicircle along the top to clear the front driveshaft:



Then I boxed in the sections that I cut, to rejoin the top and bottom halfs of the member:



Then I slapped a 3/8" steel plate to the backside for some reinforcement:



And here's some shot of the final product, after paint:



 

·
Registered
Joined
·
4,001 Posts
Man youve been busy. Looks really good. I think your truck is gona live a nice long life :D
 

·
Registered
Joined
·
7,208 Posts
That third member is about 60-70 pounds by itself. Then add the weight of the housing about 30 pounds, then the half shafts, and the diff brackets.

I'm going to say about 150 or so with everything attached.

Joe
 

·
Registered
Joined
·
292 Posts
Discussion Starter · #27 ·
Thanks guys, I'm pretty happy with the way that everything is turning out. Although, I think that the crossmember could have been a bit better. This is the first project that I've ever used a MIG for, so I'm still learning and need a bit more practice before I can consistantly lay down a good structural AND bitchen looking bead. :D All of my previous experience has been with TIG, and it's taking some getting used to figuring out the best way to control the heat going into the metal.

Vince,
I pulled the axle by myself, which was doable. I supported it with my floor jack, unbolted the diff brackets at the axle, separtated the CV's, and jockeyed out the center section. A bit tricky, but not bad at all. Just make sure you drop down the passenger side first, despite what the stupid Haynes manual says. Going in is another story, and I wasn't about to attempt that alone. I got a buddy to help, and it went back in with no trouble.

Dae,
That's the plan. =) My wife said I have to drive her for 10 more years, which is fine by me. Now on to the dozens of other little projects that I have planned....... :twisted:
 

·
Registered
Joined
·
12 Posts
Hi Jason,

Just wanted to ask re: the front diff drop ...

Is there a reason why you couldn't just install spacers between the axle brackets and chassis mounts - rather than hacking into the brackets with a plasma cutter?

I'm sure the latter was a lot of fun, but I'm just wondering if spacers between the brackets and chassis mounts would work?

I'm thinking about dropping the front diff on my Frontera (Rodeo) after a 3" suspension lift - but really don't have the equipment, time or skills to go cutting up the brackets.

Cheers,

Benn
 

·
Registered
Joined
·
292 Posts
Discussion Starter · #31 ·
Hey Benn, welcome to the Planet! Sorry that I did not see your question earlier.

The reason for the cutting & welding, is that I don't think that you could get 1.25"-1.5" of drop by using spacers. The pitman arm and drag link are in pretty close proximity to the forward bolts of the diff brackets. Unless you modified the steering linkages somehow, there would be interference with a spaced-out diff.

Also, the rear diff bracket mount is a captured stud. I'm not sure how it is captured (welded?), so maybe some of the other guys on the forum could answer that......but I imagine that it would be a PITA to swap it out for a longer one.

I'll try to put up a pic for you tonight when I get home.
 

·
Registered
Joined
·
12 Posts
Hi Jason,

Thanks for the insights. That all makes sense. Think I'll leave it for now.

As it is, I have a replacement Calmini front cross member fitted which would only allow maybe half an inch drop before having to cut into it - so it all makes for a big job.

I haven't had any problems with the CVs to date (knock on wood) - and as I use my car for work every day, I can't really afford to have it off the road.

Plenty of other stuff to go on with in the meantime ... currently working on a custom snorkel - and after that will probably fit a compressor.

I'm looking forward to seeing more pics of your Rodeo. It's looking great so far! You're doing some awesome posts - very informative - so hope you can keep it up :)

Cheers - and thanks again.

Benn
 

·
Registered
Joined
·
292 Posts
Discussion Starter · #33 ·
Howdy Benn.....thanks for the props! I've still got a laundry list of things to do to the Rodeo, but now that it's my DD the upgrades will be coming a little more slowly. Anyway, here's the pic I promised. It shows the proximity of the drag-link and the front diff bracket mount.



As for your cross member, you do not necessarily have to hack-n-weld if you drop the diff. I know that some guys have gotten by with just lowering the cross member with some bolt on extensions. I chose the custom route because it allowed for a little more ground clearance, and overall I think that it looks a little bit cleaner.

Best of luck, and let us know what you come up with. :)

Cheers,
 

·
Registered
Joined
·
2,098 Posts
I picked up a $300 2nd Gen Trooper from a coworker, I think I'll have to do the same valvetrain work. It has 197k on the OD and ticks like mad. I think I'll do some work on the 2nd Gen to get it up to daily driver status before I tear down the 3.4L in my 1st Gen (needs more power :D ).
 

·
Registered
Joined
·
292 Posts
Discussion Starter · #35 ·
Well, finally got around to upgrading the audio in the Rodeo. The previous owner had installed some aftermarket stuff, but it seriously sucked arse. Could barely turn it up with out hardcore distortion. Lucky for me, I had a decent Clarion headunit, and Blaupunkt 6x9 3-ways and 6.5 2-ways from my wife's old college car just sitting around collecting dust. :D

I decided to drop the 6x9's in the tailgate, which took a little creative positioning in order to clear the windshield wiper motor and linkages. There was some cutting and bending of sheetmetal to be done, but overall it was a pretty easy install:



The 6.5's were a little more work to install. The '95 Rodeo came stock with some crappy little 4 inchers up front, and there was no way a bigger speaker was going into the stock location:



So, after a bit of careful evaluation, I decided that the easiest place to fit them would be the rear doors where the ash trays are located. I had to do some minor sheetmetal cutting, and trimmed back the plastic vapor barrier in that location:



Although I do not have any power options on my Rodeo, there are still all of the factory hole locations for the wiring to pass through. I extended the speaker wire, ran it under the carpet along with the main wiring loom, and was able to easily fish it through the door pillar and into the rear doors. Add a little bit of split loom for abrasion resistance an viola:



After that it was just a lot of cutting on the door panels, and fit-checking to get everything to look right:





I still have a little bit of finishing work to do, but overall I don't think it looks too bad right now. The new speakers definitely had a better sound quality, but everything still pretty much sounded like crap if you tried to turn it up at all (like enough to hear it with the windows down on the highway). The old headunit was a pig, and was maxing out its internal amplifier. So, it was out with the old headunit and in with the new:



Wow! What a difference! I can now pretty much crank the ****e out of it, and haven't gotten any distortion yet. The "new" Clarion unit made a world of difference. So, for a grand total of $0 invested I would have to say that I am very pleased with this audio upgrade.

Next on the list is finding a home for my two 8" subs and 220W amp to round out the low end a bit. Stay tuned kids.......
 

·
Registered
Joined
·
1 Posts
Hi! Jeson-

Your are the kind of guy I was looking for. My rodeo leaking oil from the valve cover gasket on both sides. When I remove the spark plugs They were socked with oil. My freind changed the water pump but he put the same old timing belt. Since then there is random misfire from the engine.

So I am fixing myself this time. I removed the fan clutch with fan and fan shroud. I removed the all the belts. I also removed the upper timing chain covers on both sides. What I noticed than timing chain is very slacked on the left side at the idler polly.

This what I plan to do.

1- Change the timing belt with new one.
2- Install new volve cover gaskets on both side with new sparkplug rubber seal.

I need help from you to give me directions in regards to following Questions.-

1- What size socket is needed to remove crankshaft pullly center bolt and how to remove it?

2- Can you guide me step by step how to remove the valve cover on both sides. Left side seem to be easy but passanger side looks to me difficult. Do I have to renove the plenum on that side. Is there a simple way to remove the passanger side valve cover.

Please help me Jason. Winter is coming and my teen age daughter drive this Isuzu. I want to fix it for her early.

Help will be appreciated :?:
 

·
Registered
Joined
·
470 Posts
Hey man, any new updates on this?
 

·
Registered
Joined
·
470 Posts
Btw, you can put some 6.5s up front. You'll have to spacer the speaker out with speaker spacers but it looks and sounds good!
 

Attachments

21 - 40 of 44 Posts
Top