Isuzu SUV Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi all, wondering if someone can help me here.

My 1994 Trooper 3.2 dohc is acting up, giving very erratic voltage readings, as low as 8v sometimes. Of course, when it gets that low, the transmission gets stuck in 3rd and it begins to idle rough etc. Anyhow, I checked the belts and they 'seem' tight, so I guess this is either the battery or alternator? How do I know which one? Also, the problem seems to be sporadic, sometimes the truck runs fine, however, when it does act up, I've noticed a burning smell, like melting rubber.

Anyone have any ideas what this is? I'm thinking it's the alternator because the radio etc. seems to work fine even when voltage is reading 8v, however, the heater fan doesn't work? I've only had the truck a short time so I haven't really gotten used to 'reading' it.

Any help would be greatly appreciated as I would like to fix it myself if at all possible.

Thanks.

Dean
 

·
Registered
Joined
·
256 Posts
Get that alternator checked out! In my '92, my truck was occasionally going in to limp mode too. Well, it turned out that the power steering pump was leaking fluid into the alternator, and I didn't even know it was leaking (the alt. caught all of the tell tale drips). The end result when the alt. finally shorted was a voltage spike that blew the transmission computer. $1900 in damage!

Moral of the story: Get the alternator checked out.
 

·
Registered
Joined
·
256 Posts
Get that alternator checked out! In my '92, my truck was occasionally going in to limp mode too. Well, it turned out that the power steering pump was leaking fluid into the alternator, and I didn't even know it was leaking (the alt. caught all of the tell tale drips). The end result when the alt. finally shorted was a voltage spike that blew the transmission computer. $1900 in damage!

Moral of the story: Get the alternator checked out.
 

·
Registered
Joined
·
3 Posts
I agree with kuranosuke. My wife's saturn had something similiar to this happen to it...the burning smell was the fluid getting into the altenator and burning up. When you do smell that again....that's the first place I'd look.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top