Isuzu SUV Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1,509 Posts
Discussion Starter · #1 ·
Hey Guys, I have been having this problem with my trooper for a while now, even before the 3.4 swap. I have this intermittent misfire, I never used to be as bad as it is now. Sometimes when I start it, it purrs like a kitten, other times it seems it's running on 3 cylinders. It comes and goes, one time I took it for about a 2 mile test drive and half way through it started doing it. I just replaced the plug wires, and coil. No change. I noticed it doesnt do the cold start rev thing anymore, where it rev's high untill it warms up enough. I havent had too much time to troubleshoot it as it's at my buddys shop. Any clues? I will admit I'm not the best at diagnosing these types of problems.

Thanks
_Chris..
 

·
Registered
Joined
·
4,390 Posts
Maybe an injector leaning out? How 'bout a bad spark plug or three? Last thought is perhaps too-tight valve lash and one or more lifters are pumping up & causing valve(s) to hang open?

Just brainstorming (MMMMMMMMMMM.......Brains!!! DOH)
 

·
Registered
Joined
·
1,509 Posts
Discussion Starter · #4 ·
I dont think its lifters, just because its so intermittent. Where is the ignition module on these things? I can remember going to elemetry school in this trooper and I know its never been changed since we've had it, which is a long time lol!!
 

·
Registered
Joined
·
5,208 Posts
onebadtrooper said:
I dont think its lifters, just because its so intermittent. Where is the ignition module on these things? I can remember going to elemetry school in this trooper and I know its never been changed since we've had it, which is a long time lol!!
CHRIS , AT THIS AGE YOU COULD VERY WELL HAVE AN INTERMITENT PICK UP COIL IN THE DIST, THERE ISNT MUCH TO GO WRONG IN THOSE DIST, IF IT HAS BEEN DOING THIS A LONG TIME , I NEW IGN MODULE AND PICKUP COIL ASSY FOR THE DIST CERTAINLY WOULD NOT BE A WASTE OF MONEY, I WOULD BE WARY OF SOME OF THE BOX STORE IGN PARTS, THE CIRCULAR MAGNET , ALLSO, THYE DO GET WEAK
 

·
Registered
Joined
·
1,124 Posts
onebadtrooper said:
I dont think its lifters, just because its so intermittent. Where is the ignition module on these things? I can remember going to elemetry school in this trooper and I know its never been changed since we've had it, which is a long time lol!!
it's inside the distributor, under the rotor.

john
 

·
Registered
Joined
·
1,509 Posts
Discussion Starter · #7 ·
Oh ok, I didnt know they were in the dist. I did swap in a different dist when I built the 3.4, I pulled it out of a junk yard though so who knows how old it was.
I will replace both the pick-up coil and module an see how she runs. Hopfuly good!! I'm ready to start driving this thing again!

Thanks Guys!!
_Chris..
 
1 - 7 of 7 Posts
Top