Isuzu SUV Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I own 2001 Isuzu Rodeo LS. The day after I bought my vehicle (used) I discovered the intermittent wipers work intermittently. A month after I bought the vehicle I discovered the blower fan works intermittently.

I've read that a relay could be the cause of the wipers malfunctioning, and I have yet to find that alarm control device behind the glove compartment. What about the blower motor? I owned a 1991 Rodeo with a similar problem, and I fixed the problem by swapping the blower relay. The 2001 doesn't seem to have a relay. All fuses are fine...

Thanks in advance for any feedback.
 

·
Registered
Joined
·
18 Posts
and I have yet to find that alarm control device behind the glove compartment.
It's not directly behind the glove box...it's behind and to the right, probably above the right front wheel. It may help to remove the glove box, which isn't too difficult (two phillips head screws just under the glove box door).

You'll see two modules in there. The FAQ has more details.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
OK, I found the Alarm Control Unit.

Now, more specifics about the blower fan... some days it works, some days it doesn't. Some days it won't work, but after driving for a while it will kick in. I haven't experienced the fan dying while it was blowing; it only seems to malfunction at startup or when the fan switch is turned off.

Also, when the fan does blow, it makes an unusual rapid clicking sound that goes with the speed of the fan. It can be heard especially at the low setting. I also heard this sound from my previous Rodeo's blower before it stopped running and I swapped the relay.

Any suggestions on what I should do to fix this intermittent problem?
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top