Isuzu SUV Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
108 Posts
Discussion Starter · #1 ·
well,i went to the stoe about 2 miles,picked up some junk went back to the ol'troop started it up and sh%^$%#$%#$%t .sounded like i threw a rod,no power,runn'n like crap.get it home started looking around everything looks good no water in the oil,but no #3&4.getting hot right in the driveway.not a good day.
 

·
Registered
Joined
·
108 Posts
Discussion Starter · #2 ·
anyone have any comments about rising sun engines or oreint engines in ky?i think i'm just going to go all new(or rebuilt)pull the motor and trans.new motor(long block)new clutch,etc.got close to 300,000 miles on this one i think i got my monies worth,just to good of a vehicle to throw away.
thanks in advance for any comments.

shoe
 

·
Registered
Joined
·
108 Posts
Discussion Starter · #4 ·
its a 89 as well,i don't mind fixing it.its a great truck still checking out all my options if it needs a new motor ,i'm going all new /we'll see this week end. i don't think i'll ever get rid of my trooper,just keep building it til its all fixed or new.
 

·
Registered
Joined
·
108 Posts
Discussion Starter · #5 ·
well,as it turns out its only the head gasket!!!!!everything else looks great.just wish i did'nt pull the motor out.anyway i'll have it put back together in a couple of days.now i can get back to painting it.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top