Isuzu SUV Forum banner
1 - 20 of 29 Posts

·
Registered
Joined
·
2,102 Posts
Discussion Starter · #1 ·
Since my daily got totaled and I wasn't in a hurry to go through the new car rigmarole, I found what appeared to be a pretty dang clean 91 V6 manual for a very reasonable price.



Drove 3 hours to go look at it since the guy wouldn't take a deposit to hold it til the weekend. Understandable. It was a nice looking 20 footer. Had a new 2.8 put in 2 years ago, so I wasn't concerned about the motor. Had a fairly recent MAACO paint job (as you can tell from the overspray on everything). It drove ok, fan seemed loud, definitely needed a tune up, AC needs a recharge, but everything pretty much worked. Little rust on it, which isn't surprising as it spent time in the DC area, but mostly the overspray from the paint job coming off the unprepped frame. Not a big concern. Steering box is leaking, will need tires soon. Can deal with all of it.

In my excitement, since the motor was fresh-ish (with paperwork) I didn't think to actually check the motor over. So we signed the title and I handed the man 15 crisp $100's. Seeing as how I'm about to drive it 3 hrs back home, I opened the hood to top off fluids. Added a qt of oil, checked the belt, etc. Popped the rad cap and oh boy. Looked like oil had gotten in it. Nice rusty brownish looking aerated stuff. Called the guy, he pretty much said tough luck, but don't worry, it looked like that before and never came close to overheating. Ugh. I didn't have the means to do a rad flush, and I also thought it could just be old rad fluid, mixed orange and green and maybe some rust? Dunno.

So I had to make a choice. I had driven a rental car there. I could drive the rental back and call AAA to tow it home. Or I could chance it, drop the rental keys in the drop box, and if the rig ends up on a tow truck, by God I'm going to be riding shotgun in the sumbitch. I figured my wife, patiently waiting back home, would be equally irritated with either scenario, so I chanced it.

The fan clutch was seized so it sounded like a freakin' dump truck, and it felt like it was only running on 5. The tires were 10 years old. But I took her easy and made it home, no big deal.

Yesterday I picked up plugs and fluids and swapped the fan and clutch assembly from my big trooper. The nuts on the fan on the new one were a huge pain, all sorta pre-rounded. Stupid rusty pos. After much dirty frustrating work and a lot of PB blaster, I got the good fan on it. And there was much rejoicing. Next, I replaced the spark plugs - one was cracked! no wonder it seemed to be running on 5 - it was! I mounted up my spare MSD blaster coil, and adjusted some vacuum lines, and wow, totally different. Feels peppy!

Next on the list will be running some rad/cooling system cleaner, then flushing the hell out of the cooling system and putting in new stuff. If it become contaminated, I'll begrudgingly do the head gaskets and that ought to fix it.

I will need to get new tires, but being unsure about how much more I will need to do with this, I am going to try to score a good used set in the stock 235/75/15 size.

Ultimately the goal is to have something reliable and comfortable to commute to work and drive to/on the beach with the fam, stuff like that. If I can avoid a new car payment for a while, I'm good with that.

Must do's:
Rad flush
Steering box - either re-seal or put a good one on
Tires
Window weather stripping - backseat roll up windows are missing stripping so they rattle if they aren't either all the way up or all the way down
POR-15 on the chassis and under the carpet if/where
Recharge AC
Tint
Misc interior pieces
Adjust hood mounts and latch
Better secure the grill (few busted tabs on the sides)

Want to's:
New shocks and springs (maybe OME's for the extra load capacity)
4.77s and 31's
Limited slip
Bit of sound deadening
 

·
Registered
Joined
·
2,102 Posts
Discussion Starter · #4 ·
DSUZU said:
Nice score. If it did have some oil in the cooling system, seriously consider changing the hoses too. My experience was that the oil (even a little bit) caused the hoses to deteriorate FROM THE INSIDE. Fortunately (for me) I noticed the swelling before one blew. Dennis
That's the plan. The upper rad hose looks a little swollen already. I am going to see if any place local has the formed hoses in stock and I have plenty of heater hose left from the other trooper.

Ed Mc. said:
To get the oil out of the system, flush with a mixture of SHOUT gel (about 1/2 bottle) in 2 gallons of distilled water. You'll probably have to flush a couple of times to get the gunk out.

Follow with a bottle of Prestone Super Flush or similar. Be sure to use distilled water for the flushes and on the final refill.

I've been using Peak Global Lifetime antifreeze in my 3.4 and it seems to work well. Stays clean as a whistle. Most Napa stores carry the stuff.

G'luck with your new "White Whale", Ahab!
Thanks Ed - I already have a small jug of the flush stuff and some distilled water for the cleanings and final filling. I was going to use the ol' garden hose coupler T to flush it out between treatments. It'll probably end up half distilled and half tap water at the end and I'm ok with that! It'll beat whats in there now.
 

·
Registered
Joined
·
2,102 Posts
Discussion Starter · #6 ·
I'm 99% sure it was leak stop crap that the rad shop must have put in when they put in the new rad. It's sticky and doesn't come off of anything. I think I got most of it out and the system now has fresh coolant and distilled water in it.

AC is blowing cold now as well! Say what!!? And new tires too. Pics to come.
 

·
Registered
Joined
·
2,102 Posts
Discussion Starter · #7 ·

·
Registered
Joined
·
2,102 Posts
Discussion Starter · #8 ·
So after a water flush, a shout flush, a prestone rad flush flush, and more water flushing, this is still greeting me as I pop the rad cap. Oh well. Hopefully nothing ever leaks now.
View attachment 3

Got the AC charged up:
View attachment 2

May not be Ice cold, but it's pretty nice!

I need to fix the following in order to keep all that cold air in and the elements out:

View attachment 1

Whats missing is the window track stripping stuff that goes in the door/window frame. Rattles like a sumbitch if the windows aren't fully up or down.

Anyway, that's where we are now. When Jerry gets home he's going to let me know if he has the window parts for me, and then I'll spring for some tint and hopefully I'll be cooler for the summer months. :D
 

·
Registered
Joined
·
2,102 Posts
Discussion Starter · #9 ·
AC is making a bit of a racket when it's on, and the idle isn't perfect when it's warm - gets a little low and stumbles. Smells a bit fuelly out the back as well. So I'm going to do cap, rotor, wires, temp sensor, and O2 sensor and check timing. If that doesn't do it I have a few other things to check on the diz. It drives fine in the meantime, but would like to get it totally dialed in. Also getting some whine from the trans, so I"m expecting to crack open the drain and smell gear oil. Gonna get that done here ASAP.

Once it's running well I can move to chipping off the bubbling overspray on the frame and hitting it with rust neutralizer or POR, as well as a few body spots.
 

·
Registered
Joined
·
2,102 Posts
Discussion Starter · #10 ·
Barely made it home yesterday. Missing/sputtering barely able to accelerate. Parked it in the driveway and grabbed parts. Changed cap and rotor to good used spares, no start. Crank and fuel but no spark. Changed wires and coil to good used spares, no start. Changed the ICM on the diz, no start. Grabbed a spare diz that I had, still no start. Pulled the ECM from my other trooper, still no start. Ugh. Going to pull all my grounds and clean them well and see if that does anything. If it's not that I might have a harness problem. Cross yer fingers.
 

·
Registered
Joined
·
2,102 Posts
Discussion Starter · #11 ·
Dang, no dice.
 

·
Registered
Joined
·
2,102 Posts
Discussion Starter · #13 ·
It's making me pay for it now!

So it looks like I have spark from the coil now, but still not getting it to catch. I'm too beat to mess with it anymore today. I'm a bonafide distributor taker outer now tho I tells ya! Tomorrow I'll test for spark off the individual wires and then I'll see if maybe I can time it to run.

Could be a super clogged cat. I was thinking that as I was coming home yesterday. Felt like it was choking almost. I'm gonna unbolt the cat tomorrow to see if that makes a difference.

Getting a rental car for a week with some points I accumulated in my last job. So now I'll at least be able to get to work.
 

·
Registered
Joined
·
2,102 Posts
Discussion Starter · #15 ·
I think it's out of time now, so I'm going to step away for the day and this evening go back at it fresh. Unbolt cat, reset diz, really try to get this puppy figured out.

The diz hold down is actually easier on the white one. I have a special diz hold down bolt wrench that I use to break it loose / finish tighten it, and I've found that going at it from the passenger side behind all the stuff on that side is the easiest way to get my fingers on it. A 15mm on a 1/4" extension from above seems to be able to get at OK too.

And believe me, after pullin parts off the red one, I'm still gonna have to do everything over again on that one to get it back on the trail.

And I have the wonderful job of wheel studs and lugnuts to get to after all this. And I'm sure the one job I've avoided in my trooper "career", the dreaded A-arm bushings, will need to happen at some point. I can smell it coming!
 

·
Registered
Joined
·
2,102 Posts
Discussion Starter · #16 ·
Ok got her back running. It may have been the ICM the whole time and then I just needed to get it in time. Set timing to 12-13* btdc. Running like a top now!

Now to do the same thing with the trail trooper.
 

·
Registered
Joined
·
2,102 Posts
Discussion Starter · #18 ·
Thanks man!

I reset timing to 11*btdc, 13 was a little high. Was getting some crummy running conditions once it was warm. I have been too lazy to pull the cat off and check it out. I hoping it's the cat. Could also be fuel pump, which would SUCK. Might be a few other sensors and vacuum lines that could be replaced.

Come on lil trooper! Have mercy!
 

·
Registered
Joined
·
2,102 Posts
Discussion Starter · #20 ·
Pulled the cat and I could not see any light through it and could shake it and hear loose debris. Had a local guy run me a temporary pipe between the flanges while I wait to buy a new cat. Also replaced cracked vacuum line on the MAP sensor and removed and cleaned out the EGR. Seemed to run fine cold and warm but didn't have it out an extended amount of time yet. It's leaking a little around the crusty old cat gaskets but all that will be replaced when the new cat shows up. Actually sounds pretty good out the tailpipe. Little raspier.

This will probably be the setup for a month or so unless it starts to run bad again.
 

·
Registered
Joined
·
2,102 Posts
Discussion Starter · #21 ·
Back from vacation. Next "must do" items I hope to get done the next few weeks:

Tint (should get done this week)
Rust neutralizing and paint touch up - door bottoms are getting rough on the inside, one wheel looks a bit rough (former spare), and all the frickin' white overspray all over everything is driving me nuts.
Picking up a bunch of parts from Lorenzo's recent parts rig (nasty610's old rig) so that will be window track/seal stuff, shocks, ignition stuff, etc
All new urethane bushings in the leafs and sway bar.

That should get me into a good spot to determine whether I want to keep it or sell it. I love driving it and messing with it, but I hate driving it in traffic to work. If it had 200hp it would be different. Honestly I could spend another $5k on this thing easily before I'd say I was "done" with it. But that's a lot of money and more importantly a lot of time I don't really can't spend at this point. I'd love to tinker on it every weekend, but I just don't have that luxury and I can't prioritize it over so much other stuff. So I'm going to take it this far and see what I really want to do.
 

·
Registered
Joined
·
2,102 Posts
Looks like my pics done broked.

I will go back and edit if the site admin isn't going to undo what he did.

But a little progress for today:

IMG_20180622_124533.jpg


IMG_20180622_124545.jpg


Tint, check. Much nicer to drive in the hot hot sun now.

Heading to Lorenzo's for more parts later this afternoon.
 

Attachments

·
Registered
Joined
·
2,102 Posts
Discussion Starter · #24 ·
Thanks Jonathan! Hope you are able to get in a little tinkering time on yours here and there.

The new tint make a YUGE difference. Holy Moly. So that has been fantastic. Have to recharge the AC every few weeks, but I can cope. I've been recently dealing with a bit of a rough idle at start up, esp if I left the AC on from the day before. Had a vacuum line come off, but after reattaching, it didn't seem to make much of a difference. Once it's warm and going, it's no big deal. Hoping to get it straightened out after the next round of tinkering.

I got my window track pieces, ignition coil, catalytic converter, shocks, interior dome light, carpet strip hold down, and window crank for this rig from lorenzo (nasty's old trooper), as well as the dizzy for my red rig. Still need to get a new fan clutch for that one - the one on nasty's trooper was in pretty good shape but not super duper buttery smooth, and new ones aren't expensive, so I figured I'll just order one this week. Be nice to have big red back on the road! I need to get some more 4 low therapy and fast.
 

·
Registered
Joined
·
2,102 Posts
Did some rust-neutralizing. Armed with a flathead screw driver, a wide scraper, and a wire brush, I got rid of as much loose scale and flaking overspray. Then to the pressure washer to get as much else as I could get. Then a couple cans of rust converter to the frame, body mounts, and a few spots on the rockers and door bottoms. Then I got a few cans of flat black to get the inner fenders and front and rear skid plates, as well as a can of hammered black for the grill. Looks WAY better.

MVIMG_20180708_203744.jpg


IMG_20180708_203914.jpg

Screenshot_20180708-205307.png


Next I want to do the bumpers and wheels. Anyone know if there's something off the shelf that matches close enough to those grays?
 

Attachments

·
Registered
Joined
·
2,102 Posts
Discussion Starter · #27 ·
I removed them to get to some spots with the rust converter, and then put them back on and might have given them a mist of the rattle can. They had a bunch of white overspray and grime on them already.

In other news, I did a little trial and error on the front bumper paint. Cast Aluminum ended up too light, so I'll have to go grab something else - probably the Argent silver. I had grabbed a couple cans of different silvers and was initially going to pull the rear bumper and do it first. Well, the first rear bumper bolt broke off so I figured I'll save that project for a later time. I need to bang some dents out of it but I don't want to break every bolt in the frame getting it off. Ugh. Time to get some of that high test Kroil or whip up a custom batch of penetrating oil and soak everything.

Rust also struck when I tried to get the stupid O2 sensor out. I've managed to round off the dang thing with a 7/8-22mm O2 sensor wrench, which isn't good. It's closer to 22mm so I'm going to try to get a 22mm box end wrench on it to get it out, after multiple further judicious applications of penetrating oil. It mustn't have had any anti-seize on it when it was installed.

Along with getting the 02 sensor done, I'm also going to pull the TBI unit and rebuild/clean the heck of it and every sensor and hopefully get it running tip-top and get rid of some of the rich fuel smell.
 

·
Registered
Joined
·
2,102 Posts
Discussion Starter · #28 ·
Been driving the heck out of this thing. Replaced the crummy split aftermarket shift book with a nice used one from MrDunge. But, over the weekend, I was gifted a nice commuter car (07 Camry) by my father in law. So after I finish out a few projects left on this, she will be going up for sale. I'm going to install a rebuilt TB, leaf n shackle bushings, new sway bar bushings, shocks, and the steering box I'm picking up from Lorenzo. That should take care of most of the minor issues it has left. Maybe a little touch up here and there and give it a good scrub down. If anyone is interested in a solid trooper, let me know.
 

·
Registered
Joined
·
2,102 Posts
Discussion Starter · #30 ·
Got front sway bar bushings and end links done, 1 front shock, and one rear shackle bushing set in. And the spare throttle body is still in pieces :lol: Getting there tho!
 
1 - 20 of 29 Posts
Top