Isuzu SUV Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey all. Very new to isuzus, as I just got a 1995.5 rodeo 3.2 and I finally got it running. But no matter what, when I start it, it shoots up to around 2.5-3k rpm for a while then dives down to around 1k. Is this a normal thing for it? Because we forgot to plug a small hole on the throttle body, and ran it like that and I don't know if it programmed itself to run like that and screwed it up or what. I'm going from a 1970 bug so big technology shift lmao
All help is appreciated
 

·
Registered
Joined
·
6 Posts
I have a similar issue. It's inconsistent for me, sometimes it lasts my whole 15 minute drive to work and sometimes it dies down before I leave the neighborhood.
 

·
Registered
Joined
·
778 Posts
My 99 Trooper (3.5... not identical but very similar) used to do that as well. It never bothered me enough to fix it, but I had to replace the fuel injector o-rings when I replaced a stuck thermostat and it hasn't happened since. (3,000 miles ago) I also replaced the intake gasket at this time, but I suspect injector o-rings as a fuel leak into the engine would increase revs where an intake leak would cause it to sputter/stall since it would run too lean.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Ah okay. Because it stops itself, but letting it idle while I'm working on it, randomly it will shoot up Abt 200 rpms for a minute and then drop. I'm not super worried as long as it doesn't get worse
 

·
Registered
Joined
·
778 Posts
Interesting... I'm not saying I found the solution, its pure speculation but I thought it might be a start for you
 

·
Registered
Joined
·
3 Posts
I have a 00 3.5 trooper. Summer mornings starts at 2k rpm then goes to 1200. When hot in the afternoon it starts at 1800 and goes down faster to the normal 1200 or so. So the coldee start ups the higher the rpm iv noticed. However I have 3 digital Throttle position systems. 1 i got with the car that ran higher and kept giving me a error code i and made it sluggish with low power. I got my 2nd TPS from a 3.5 rodeo and its the one im currently using without problems. Then my 3rd i bought new and idle starts at 4k+ rpm but i kill it before it goes higher. Figuring out these need to be adjusted by a mechanics computer. . I also cleaned the entire air intake system and throttle body using proper CRC cleaners and it ran a little smoother.
 
1 - 6 of 6 Posts
Top