Isuzu SUV Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hey i just spent $1800 getting my fuel pump and catalytic converter(whole muffler system) replaced and now the car is doing something else. I have a '94 Amigo and it is hesitating when i give it gas. It has actually started dying. when it hesitates there is no go to the power it just sits there and then it will kick and go. It is kind of like a cough.

The place where i had it "fixed" is telling me the mass aorflow sensor is out they think. Anyone have any ideas? it is a $260 part and i am out of money.
Thanks guys
Doug
 

·
Registered
Joined
·
825 Posts
$1800!!!???

i checked with some places around town- they said they would do an entire new esaust, including new cat and muffler, for $400. What did the other $1400 go to? a gas pump?
 

·
Registered
Joined
·
894 Posts
I'd run to another mechanic.

Could be the MAF, but I think you would get a CEL with that. Easy enough to unplug and see if the symptoms stay the same, go away, or get worse.

Could be a bad fuel pump or plugged fuel filter, vacuum leak meaning the MAF is good and extra air really is getting into the engine, dying alternator, and a few other culprits.

Have you tried checking for stored trouble codes? How long after the work did the symptoms start? Any other information (e.g. flashing dash lights?, after x miles?, mileage worse lately, etc.) you can give us may help the Board diagnose this.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
thanks guys, sorry i have been away from my computer but will check the things you said. I did replace the fuel pump, that was the first thing at $1000 then the cat converter was clogged so they replaced that and the muffler.

I do get a CEL and when i let off the gas it goes out. same as before i had all the other work done. they are telling me they think it is the MAF sensor but i do not have an extra $280 to see if it fixes the issue.

IF i was to try unplugging the MAF how would i do that? it all started about 2 1/2 weeks after the other work was done i guess. maybe a little longer. i do not have a code reader to check for the stored code but may try to have it read. nothing else really stands out to tell you. no flashing light or anything just randomly does this coughing thing.

any more help you guys could give would be greatly appreciated.
thanks
 

·
Registered
Joined
·
1,286 Posts
Your vehicle is pre-OBDII, you can check the codes manually without a code-reader.

First step is to obtain a Chiltons or Haynes from a local auto store that has the codes and the instructions to obtain the codes.

Maybe someone will chime in with an Amigo that can help. If not, then you can inquire over at the 'Wire: http://www.4x4wire.com/isuzu in the tech forum.

With all that exhaust work, did the also install a new oxygen sensor? It might be running stupid rich causing the hesitation and stalling. For that kind of money, it should be a gold plated oxygen sensor :shock:

Good luck.

Cheers,
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top