Isuzu SUV Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
I have seen mention of this talked about elsewhere but could really use a definitive answer if anybody knows.

I have a 2001 Rodeo 3.0 with 87k on it. The check engine light and Check tranny light (flashes) both come on at the same time, with no apparent problems other than losing overdrive when this happens. It then needs to be reset, but it comes back on again after about 95 miles have been driven.

Has anybody heard of this before?

Thanks for any help you can offer.

edit: It also has a bad fuel sending unit. Can only put about 14g in it when showing empty. Could this be causing the lights?
 

·
Registered
Joined
·
11,921 Posts
When the CEL is illuminated and the Check Trans lamp flashes OBDII has detected a transmission problem, which probably is related your loss of fourth gear. Next time it happens read out the OBDII diagnostic code instead of clearing it. The code is telling you what problem OBDII has detected and will help you determine what needs fixing. The fuel sending gage problem is probably not turning on the CEL, but you have to read the codes to find out. Autozone will read the codes for you or you can buy your own scan tool, in my opinion every owner with an OBDII equipped vehicle should own a scan tool.
 

·
Registered
Joined
·
56 Posts
Fuel Sending Unit did trigger the CEL on mine.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #4 ·
I have the scanner and will read the code when it happens. So the transmission is throwing the CEL and not the other way around.
 

·
Registered
Joined
·
11,921 Posts
For most OBDII transmission faults the CEL will illuminate and a DTC code stored when a Check Trans lamp flashes, in a few cases only the Check Trans will flash. In this instance, since they both occur at the same the time it is probable they are related. Transmission OBDII codes are those faults that can be detected electrically and usually involve one of the five solenoid control valves. Be advised that not all scan tools can read transmission codes. What brand and model do you have?
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #6 ·
It is a 2001 Rodeo, V6 with automatic transmission. The check transmission is flashing and it illuminates the CEL at the same time. The 3 times it has happened was almost exactly 95-100 miles after it had been reset the last time and also I have been driving at 60-70mph on the highway. Just seems a little strange to me, that it comes on almost the identical amount of miles after being reset.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #7 ·
Ok, I got the error code it is P1870 Transmission Component Slipping. It has only happened so far while driving on the Highway at approx. 65mph and always about 100 miles since being reset the last time.

Has anyone seen this before and how did you get it resolved? New Transmission? Torque Converter, Flushing all the fluid? any info is greatly appreciated.
 

·
Registered
Joined
·
11,921 Posts
P1870 indicates the torque converter has too much slippage. You probably have a defective Torque Converter Clutch (TCC) but it could be caused by a transmission TCC hydraulic problem. Recommend you go to a transmission shop and get their opinion.
 
1 - 8 of 8 Posts
Top