Isuzu SUV Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
Help needed with a specific CEL code...
Yesterday, while turning on the engine, my 98 Rodeo (89K), had a little difficulty starting; I should have kept the ignition going little longer, my fault... Then, the second try did not go through. Engine started at the 3rd try... 2 miles after taking off, Check Engine Light came on.
I had it read at the shop this evening while having an oil change. The code is 1404. I called the dealer and I was told that it is related to EGR.
Note that the CEL was not on anymore, when I picked up the car. Is this because the problem was intermittent or because it was simply "read"?
Should I take it to dealer with the code 1404, even though the light is off now?
Thanks very much for your help and time in advance!
 

·
Registered
Joined
·
7,208 Posts
This is something you can take care of yourself. All you need to do is take the egr wire loose and take two bolts out. Then plug off the big hole and then start the engine and spray a whole can of oxygen sensor safe throttle body cleaner into the small hole with the engine running. Next, take the egr valve itself and spray more cleaner in it and let it sit. Spray it out again and then work the pintle back and forth to loosen any carbon build up in the egr. Now for what took car eof mine. Push the pintle down as far as it will go and twist it back and forth. Spray out a few more times and reinstall. You can unhook your battery to reset the computer or you can just let it go through enough start cycles to get rid of the light.

My 98 did this about 20,000 miles ago and I have not had any more CEL's since. It's a pretty easy job even for a novice.

Joe
 
1 - 2 of 2 Posts
Top