Isuzu SUV Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi, I'm new to this forum. Abel is the name.
anyway.

I just changed the oil in my '93 trooper (v6) and the next day, it started hesitating, but only when I really wanted to accelerate. If I drove like a gramma, I would not have any problem.

It has enough oil, and the right kind. I changed the fuel filter, I ran techron through the gas tank. I'm also going to replace the plugs and wires.

I don't know what else to do. It's loosing power, especially in 3rd gear, when I'm accelerating. Now it ticks while I'm driving. It used to tick for only a minute or two while warming up, now it does it more....

I'm a Jeep Cherokee fan, and this is my first Trooper, So I could use any help. I've done tons of stuff to my Jeep, but I'm lost with this Trooper.

Thanks
 

·
Premium Member
Joined
·
5,577 Posts
These may be two different problems. I won't discuss the valve tick, other than to say that you should try changing your oil. The power loss under heavy acceleration/load can be attributed to spark plug wires. Try moving the current ones in the clips. Slide them 1" alternately (#1 1" left, #3 1" right, #5 1" left, etc). If that fixes it, order a set from St. Charles. They won't be cheap, but they will last much longer than the aftermarket ones.

-Tad
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top