Isuzu SUV Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I bought a 99 amigo 6cyl from river head ford the hubs were shot [no 4wd] i repaced them with bear suspension hubs I hope thats it isnt it ?Its an automatic . on the drivers side it looks like theres something missing theres 2 rubber tubes from 2 steel lines just hangin out and on the same side on the valve cover to the rear thers an empty nipple .and it stalls all the time espesialy when braking should i shoot myself? :?: :? :( :cry:
 

·
Registered
Joined
·
79 Posts
no shoot the shady [email protected] that ganked you. :evil: actually, don't shoot anyone - violence never solves anything.

I'm sorry to hear of your situation. Unfortunately it's buyer-be-very-aware when dealing with used cars from dealers(or anyone for that matter). It seems extra shady in the tri-state area for some reason. My first car was a Sentra with 40k on it and it ended up being a Jersey chop-shop POS that probably had 140k.

Hopefully someone with Amigo knowledge will chime in and help you try and get it sorted out.

Good luck.
 

·
Registered
Joined
·
192 Posts
medic54x1 said:
I bought a 99 amigo 6cyl from river head ford the hubs were shot [no 4wd] i repaced them with bear suspension hubs I hope thats it isnt it ?Its an automatic . on the drivers side it looks like theres something missing theres 2 rubber tubes from 2 steel lines just hangin out and on the same side on the valve cover to the rear thers an empty nipple .and it stalls all the time espesialy when braking should i shoot myself? :?: :? :( :cry:
Your Amigo should not have any hubs because of the shift on the fly design. So there might be another issue with your 4wd. As for your other problem, my suggestion is to take it to an Isuzu Dealer for an inspection to see what's missing or not connected properly. Malstrom Isuzu/Suzuki in West Islip(on Sunrise Highway) is good with Isuzu's as they only sell Isuzus and Suzuki so they cater well to Isuzu Owners. I was just there and they have a left over 03 Amigo(Rodeo Sport that is) on the showroom floor so if you have too, just pop the hood and look for yourself.

Do you have any warranty from the selling dealer? Most of the times from big dealers, you get a simple 30 day warranty or they normally try to sell you an extended warranty. I don't know any rodeo or amigo owners anymore so if you can find a rodeo/amigo owner on the street, just ask them to pop the hood for a look.

Let me know if you have any other questions and I will try to help out another NYr! :)

Cheers,
Con
 

·
Registered
Joined
·
591 Posts
Medic- I'm thinking along the same lines as Conman. Your 1999 came stock with solid drive flanges (no ablility to disconnect). Same type of setup used for years by GM/Jeep/Dodge :shock: It is possible someone retrofitted it with manual locking front hubs. This is possible on 1998-2001's. Thanks to the guys on this site we have these articles! :D Check here: http://www.planetisuzoo.com/articles.htm/50 Is that what you have? The most common 4x4 issue with these trucks is a frozen shift on the fly actuator. Is an electric motor that locks/unlocks the front axle. Check here: http://www.planetisuzoo.com/articles.htm/65
G/luck
Joel
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top