Isuzu SUV Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
On my 2000 Rodeo LS 4x4 when you crank it it is hard to crank, and once it does it will idle really rough. it will idle high and then low and then cut off, you have to go through this 2 or 3 times to get it cranked and then it runs fine. I've cleaned the fuel injectors and replaced fuel filter. I've noticed that once it cranks, if you rev it up some it seems to help it stay running. Does this sound like a fuel pump? If not any other ideas??
I am about to take it to Isuzu, but im wondering what the chances are of it being anything thats under power train warranty, and even if it is what the chances are of Isuzu admitting that.

Thanks for any response
 

·
Registered
Joined
·
52 Posts
I have not seen F/P regulator problems on the 00-03 models.
If you are over 12,000 miles it may cos a bit to correct the condition but have your dealr check for calibration updates for your PCM. The reason you will have to pay for this is that Isuzu cosiders it an adjustment, which is only coverd for the first 12,000 miles. If that dont work pull one of you spark plugs it may have champions in it, if so replace them with Nippendensos they are a bit expensive but they work very well with this very sensitive and complicated ignition system
 

·
Registered
Joined
·
591 Posts
Jon- could be a bad intake manifold gasket causing the engine to draw too much air at startup & idle. Hard starts, erratic idle.
G/luck
Joel
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top