Isuzu SUV Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
on my 1991 trooper.
however the oil pressure gauge, and temperature gauge on the same panel work just fine.
i just bought the trooper a week ago, and the seller informed me that it always worked. and then the trooper was parked for a while and not driven. When it was started up again, it just didn't work. it has plenty of gas, but the gauge is stuck on empty.
any idea what might cause this, and what i should check for??

thanks.
-jason.
 

·
Registered
Joined
·
2,897 Posts
Most likely to be the sending unit, especially since the vehicle sat for a while. First check the wiring at the sending unit, easily accessed if you look at the fuel tank viewed from behind the passenger side rear tire. Of course it could be the dash mounted gauge but more often it is either the above mentioned wiring where it connects to the sending unit or the sending unit itself.
Thinking there is three wires coming off the sending unit, one is ground, one goes to the gauge, and the last one goes to the low fuel light. Someone else chime in, as I remember grounding a wire at the sending unit and my fuel gauge went to full, confirming my gauge was ok but I'm hesitant to suggest that, been a while since I did it and can't always remember as I should!
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #3 ·
ok, that gives me a good starting point. I'll check it out tomorrow in the daylight.
I'll let you know what happens.
Thanks!

-jason
 

·
Registered
Joined
·
192 Posts
Mine has been out for a while now so I've been using mileage to track how much fuel I have. I'll have to check mine to see if it's a simple fix. If not then I don't care lol
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #5 ·
airhead rider.... you were right. it is was the wiring at the sending unit. not sure if it's a permanent fix, but i jiggled the wires around a bit, and started it up, and voila! my fuel gauge went up to a half a tank! let's hope it keeps working, but if not, at least i know where the problem is.
thanks for your help!

-jason
 
1 - 7 of 7 Posts
Top