Isuzu SUV Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I've spent some time searching posts and I know this problem has come up before: I have a 2000 rodeo and the gas guage crashed on me (check engine light went on, guage was spastic, tell-tale signs). I replaced the FSU with a new part. Now, although the check engine light has gone off, it appears my cars computer cannot read or detect the new FSU, as the guage reads empty even when the tank is full. The connections from fsu to computer appear sound since the check engine light is off. I tried disconnecting the battery, but nothing still. I know other people have run into this problem; what is the fix? I would like to avoid the dealer if possible
thanks, and merry christmas
 

·
Registered
Joined
·
7,209 Posts
I'd try a battery disconnect for about an hour first. You may still end up having to take it to the stealer.

Joe
 

·
Registered
Joined
·
19 Posts
I am no mechanic but if the FSU is the fuel level sending unit, more than likely it wasnt install correctly or the float is stuck. You can check without removing it by doing a resistance check. 17 ohms on a full tank if you check at the sending harness. if you disconnect at the harnes you should have 3 slots and the top locking tab. Hold the tab at the top and the one in the middle is your positive lead and the one on the right is the negative lead.

Half tank 60-100 ohms,
Empty 120 ohms or 200 ohms for the late models.

Or you can go to the top of the sending unit the X shows some slots but hook your leads - Positive to the p slot and Negative to the N slot. Sorry for the crude drawing if needed I can scan and send you a copy of the page.

lllllllllll
l X x l
l l
l l
l Pl
l --l
l N l
lllllllllll
 

·
Registered
Joined
·
7,209 Posts
There is a computer reset needed for some of the FSU replacements. When i did my 98 Rodeoport is wasn't necessary. I put it in filled the tank and it has read fine ever since.

Others have had to go to the dealer and get their computer reset for the new unit.

I don't have any idea why it would be necessary? But it is.

Joe
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #7 ·
the FSU kind of works. when i fill up, it takes about 20 driving miles for the guage to slowly work its way up to full, and after that, the guage works fine, until i have to fill up again. my guess is that the float is stuck. i tried unplugging the battery for a few hours, and that appears to have allowed the computer to detect the new unit.
thnx
 

·
Registered
Joined
·
825 Posts
sorry, off topic...

every time i see "FSU" on here... i for some reason my mind still accociates it with some aquantances I had back in highschool who drove around a huge diesel K5 blazer and had a 2 man team called the "F&^k S**t Up" club, officially, they always called it their "FSU club". They basically were out to vandalize everything... I didn't approve much, but did find it rather entertaining at the time.

sorry.... continue...
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top