Isuzu SUV Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter · #1 ·
Had my 2003 Rodeo for about a month now and its a great ride other than the crappy suspension. MY quesiton is...Sometimes, not all the time, starting out in first gear the engine seems to race or it feels like the tranny is in a very very low gear and feels like the engine is putting in the twice the effort with half the power. After switching into second the noise seems to calm down. Also almost sounds like a huge blower fan is on but I cant imagine a fan making that much noise. Other times I will not hear this at all. There is a noticeable different in power when this happens, seems like the engine is totally overworking itself for no reason. Has anyone else ever experienced this? I used to have a 89 Astro van that used to scream in first gear as well, never found out the cause buts it very annoying.

Thanks
 

·
Registered
Joined
·
1,369 Posts
Sounds like your fan clutch is kicking in. This would not explane the
loss in acceleration. Time it to be certain. The noise just might setting
you off. I am not insulting your judgement:)

The fan clutch is engaged when you first start your engine cold. Note this
sound. It is only for about 5 sec or so untill the clutch fluid circulates.

When you suddenly accerate your fan is probably on cooling best it can
than it "turns off" because of the extra RPM.

As for your suspension. Remember it is a truck, and a real one at that.
I drove a few and I only wish that they had the adjustable suspension
to make it stiffer. But I do think a stock auto adjustable rate shock
would be better. Something like the Monroe Sence a track. Get the
Rancho 9000x shocks you can choose between 9!!!!!!! settings.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top