Isuzu SUV Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
179 Posts
Discussion Starter · #1 ·
So my Rodeo is in the shop today. I've had a seemingly brake related metal rub sound for about 4 weeks now (hit the brakes and you hear a rub - rub - rub sound from the front pass.). I replaced the rotors and pads on the front two weeks ago but the noise remained.
Friday, this noise was still happening but a new noise started- a banging noise that I think is from the differential area of the front end. Not sure what this is.
**Any thoughts?
I do have manual hubs. They're unlocked (4*2) when this occurs. I know that the hubs are unlocked from the axle.

Also, I've got a whine noise that seems to be coming from the transmission. Happens only after the vehicle is warmed up. Happens stopped or moving but is most pronounced when stopped or in first.
**Any thoughts on this one?

The truck is in the shop right now so we'll see what they say (also doing the frame rust recall repair). I'd just like to have an idea of what this might be and how much this should probably cost to repair.

Thank you all
 

·
Registered
Joined
·
179 Posts
Discussion Starter · #2 ·
33 reads and no responses! :)

So the shop claims that the (new) rotors are warped. That they are causing the banging sound and the metal grinding sound. They also can't hear the whine sound from the transmission.

I still maintain that I did the brake job just fine. I wish this thing had rotors that just slipped on over the lug nuts! If it did, I'd have time to pull the rotors off again this week. Lucky me, I get to pay the shop to do the 5 hour job. Fun.

Really no one has a thought on the transmission whine? I'll try to take video/audio of this and post it up at some point.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top