Isuzu SUV Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
:shock:
OK, I'm new here, so I hope you guys can help me. I have a 96 Rodeo V6 4WD. I washed it yesterday, and now when I press the brakes the parking lights, including the dash lights all come on. It is just as though the light switch were in the parking lights position. I even get the warning signal when I open the door. As soon as I let off the brake, they go off. Also when I set the cruise control, turning on the lights turns off the cruise. Any ideas??? I really didn't want to take it to the shop if I didn't have to. Thanks. Great message board by the way.
 

·
Registered
Joined
·
368 Posts
It might go away on its own, you probably got some water where water was never intended to go. It might take a bit to dry. If it doesn't, my guess would be water in a wiring harness somewhere, or a relay.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #4 ·
I do have a wiring harness for a trailer. I noticed the door on it that keeps water out is broken so it flops up and down instead of staying shut. I'll check it today and see if it has dried up and the problems stop. This may be the whole cause. That would be a nice easy fix.
Thanks Guys
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #5 ·
OK it has had plenty of time to dry out, and I disconnected the trailer wiring harness. No change. All parking lights still come on when I hit the brakes. Anything else you guys can think of? Also yesterday when I drove it, the parking brake indicator and the rear abs indicator lights were on. I switched it off and started it back up a few minutes later and they went out. :(
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top