Isuzu SUV Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
257 Posts
Discussion Starter · #1 ·
having almost gotten my truck fixed one code was just driving me crazy, took it to a mechanic and he told me that its the Ignition Control Module.this is for a 2001 Rodeo V6 4x4, having a tough time finding this part, is it actually a part of the ignition coil?? If so how do I determine which one is needing to be replaced???
 

·
Registered
Joined
·
11,877 Posts
A 2001 Rodeo has an Ion Sensing ignition system, this system was introduced in 2000. It eliminates the knock sensor and camshaft sensor. It is the electronic module mounted on top of the intake manifold (aka common chamber), it is very expensive. Actual failures are uncommon, what DTC is set and what symptom do you have?
 

·
Registered
Joined
·
257 Posts
Discussion Starter · #3 ·
DTC???? as far as symtoms, lets start from the beginning........This thing has been a serious money pit...........Have had the tranny rebuilt, and had to get a new head, well as I was putting on the head with a 3/8" driver one of the head bolts went through the side of the engine block.......ouch new engine, found a used engine with 40,000 miles on it for 1200.00, upon getting it back from the mechanic, the CEL came on and would flash under acceleration.......had to replace the intermediate pipe, and all 4 O2 sensors at one point had 21 codes pulling, now just getting the infamous p0300 code, the plugs are new and the ignition coils visually look ok, and are all in the correct place, as #6 is different. Thats where I'm at. Its drving alot better now, but still has CEL light and still flashes under acceleration, not nearly as hesitant as it was.....but obviously cant get the damn thing to pass inspection.
 

·
Registered
Joined
·
257 Posts
Discussion Starter · #4 ·
I think I got oem plugs, but Im not 100% sure this was about 6 months ago when I did that. They were denso or ngk???
 

·
Registered
Joined
·
1,390 Posts
Just to chime in I had my plugs replaced as well and soon after my CEL would flash under acceleration as well. Took it back and they put OEM plugs on and never have a problem since..
 

·
Registered
Joined
·
11,877 Posts
DTC means diagnostic trouble code.
DTC P0300 can be caused by several different problems, usually a vacuum leak. A defective lower intake manifold gasket is a common problem.
Driving with a flashing CEL, is not recommended. You may melt down the catalytic converters and will have a bigger expense. I am 95% certain your problem is not the Ion Sensing module. It is probably not a coil either as no cylinder specific DTCs are set.

The requirement to use a certain brand of plug is nonsense!
 

·
Registered
Joined
·
257 Posts
Discussion Starter · #8 ·
Also I still have a bit of an exhaust leak from my intermidiate pipe as on one side I prolly need to doulbe up the gaskets or get some JB weld in there
 

·
Registered
Joined
·
257 Posts
Discussion Starter · #9 ·
Its is p0300...........what is the piece on top of the plenum, it has 3 plus two on one side and one on the other??
 

·
Registered
Joined
·
257 Posts
Discussion Starter · #10 ·
so from what I can see this is the ION sensor module??? anybody else want to chime in?
 

·
Registered
Joined
·
257 Posts
Discussion Starter · #11 ·
Could not running the denso plugs be the issue here??? Im pretty sure I got NGK I got them from autozone
 

·
Registered
Joined
·
257 Posts
Discussion Starter · #12 ·
Is rock auto the best place to get these plugs, Im paying about 6.00 a piece??
 

·
Registered
Joined
·
257 Posts
Discussion Starter · #13 ·
Think I should order the intake manifold gasket at the same time??? and do I need both the upper and lower (felpro??)
 

·
Registered
Joined
·
257 Posts
Discussion Starter · #14 ·
Well I got 6 of the denso, the felpro intake manifold gasket and a fuel filter from advance auto parts shipped for 68.00 using code BIG35 provided by another memeber here thanks!!!
 
1 - 14 of 14 Posts
Top