Isuzu SUV Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
89 spacecab 2.6 cluster to a 91' 2.6l spacecab.

Dash is the same I noticed the cruise control handles are on opposites the 91 has it in a horrible spot for some reason like it was meant for a RHD ahah

Has no tach and no oil pressure gauges on the 91.
 

·
Registered
Joined
·
7,076 Posts
If it physically fits then no problem there but dont expect the gauges to work. If your lucky the wiring might be there and you can add an oil pressure sending unit. If not you will have to add the circuits in yourself.
 

·
Registered
Joined
·
755 Posts
In my '94 Amigo, the wiring was already in place, all I had to do was connect the new cluster. Everything worked quite well. Maybe yours is going to be that easy, too!
 

·
Super Moderator
Joined
·
2,409 Posts
It will work, the only thing that won't
is the oil pressure gauge, you need the sender for that to work.
 

·
Registered
Joined
·
90 Posts
Just for reference...

When I did mine, the donor had come from a V6 Rodeo. It still worked, but the tach was way off. There is a pot inside the cluster though that I found and was able to adjust it back to read correct for the 4 cyl.

Blast from the past:

-----------------------------------------------------------------------------
Instrument cluster:

Don't have any pics of this one yet as I did it a couple years ago. Someday I will take it back out though and shoot a couple.

Basically, if you have an 'S' model Amigo, you don't have the tach, oil pressure or a couple other gauges. If you find a cluster with the tach from a junkyard donor, it's a pretty easy swap. The donor can be an Amigo, Rodeo or P'up. I'm not sure about Troopers but it'll be obvious if it looks the same.

The speedo cable and wire connections are all the same. Just check all the bulbs in the back of the cluster to make sure you have them all. If I remember right, my donor was a 2wd and I had to put in the 4wd indicator bulb.

There is also an additional sensor to make the oil pressure gauge work. If you just plug the cluster in, the pressure will read 110 all the time. This gauge does not use the on/off, single wire oil pressure switch that screws into the passenger side of the block. It requires a second pressure sensor that screws into the oil filter mount casting.

The hole is there in the casting, but plugged. Just unplug it and screw in the sensor. It is a 2 wire sensor and there are connectors in the wiring harness for the sensor. They're hanging down above where the sensor goes, up in the area underneath the battery. Plug them in and your gauge will work.

The last thing you may or may not have to do. If the cluster came from a donor with a 4 cylinder engine, your tach will read correctly. If it came from a 6 cylinder engine, you'll be reading about 2000 rpm when you're actually at 3000 rpm. This is an electronic tach though, and there is a pot inside the casing that you can adjust it with. I took the back off to locate the pot. Sorry, no pics but it is pretty obvious. It should be oriented so that if you're looking at the front of the cluster as you would in the truck, it's above and behind the face of the tach.

To access it, drill a small hole in the casing above the pot so that you can get a small, skinny jewelers screwdriver through the casing to reach the pot and adjust it when it's back together. You'll likely need to take it apart to find exactly where to drill this hole. Once that's done and you can find the pot with the screwdriver through the hole, take the cluster out to the truck, plug in the electrical connections to the cluster and hook up a calibrating tach to the wiring harness under the hood (there's also a free connector in the harness above the front right wheel for plugging a tach into).

Once you have the calibrating tach hooked up, rev the engine and hold it at a steady rpm on the calibrating tach. Turn the pot in the cluster with the jewelers screwdriver to adjust the tach in the cluster to match the calibrating tach. You might want to try it at a few different rpm's to make sure it's accurate. That's it. Put a dab of silicone over the hole to plug it and finish installing the cluster.
-------------------------------------------------------------------------------------

--Dan
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #8 ·
Thanks for the reply. same truck same engine different year.

89 cluster with tach want to put in a 91 without the tach. I also have the parts vehicle still so by right I should be able to hook up the sender and maybe it would work? I would assume it has the wires in the harness already
 
1 - 8 of 8 Posts
Top