Isuzu SUV Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
I just bought a '96 Rodeo w/120K miles and an auto transmission. Trans seems to shift smooth, except when I put it in Power Mode yesterday and did a quick acceleration onto the highway. After that the trans shifted hard to each gear, making a very audible noise. I let it cool off for a few hours and drove it home, taking it easy this time. No noise or hard shifting.

I don't have any maintenance records so I have no idea when the trans fluid was changed last. From other forums that I belong to I've read that Redline synthetic trans fluid is very good stuff and is great for older trannys. I'd like to get my fluid flushed and filled with it. Anyone have any experience using it?
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #2 ·
Hmm, i guess not, huh?

Well, I ended up getting the trans flushed at the dealer. Turns out that they put in full synthetic now as standard, so I'll just stick with that.

It did make a difference too. Shifts much more smoothly and quietly.
 

·
Registered
Joined
·
45 Posts
Don't worry, you're not the first to not get a reply to a post :evil: -- sucks, doesn't it?

I had tranny shift problems in a 97 Rodeo. I changed the fluid and put in a quart of Lucas Oil transmission fluid restorer to help the fluid I couldn't get to (torque converter). It's run excellent ever since.

Low fluid can really make the 4L30 shift like hell!

How much did the flush cost? I thought about having that done next time, but I'm not sure I want to spring for it!
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top