Isuzu SUV Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter · #1 ·
Ok, so a few moths ago a buddy of my was rolling down the rear passenger side window and it crapped out and fell down inside the door. we pulled it back up with pliers and duct taped it up for a few weeks until i could send it in to fix it because my dad didnt want me screwing around with trying to fix it. well today my girlfriend was in the passenger seat and the front window did the same exact thing. so, not wanting to get screwed over for $500 bucks again, i pulled off the interior parts of the door and it looks like there is a wire that pulls the window up and down and one that keeps it in place. the top wire (the one that controls the window had been disconnected and it seems like the mechanism is jammed up or something and ther isnt enough wire to reach the point where it connects. so now the window is tied off with straps for the weekend until i can get back and fix it.

these things seem to have a habit of crapping out on me. i just cant wait for the next one. :roll: ill let you guys know how i end up fixing it just in case this ever happens to you guys and if anyone has any idea what im talking about and has some suggestions let me know.
 

·
Registered
Joined
·
11,467 Posts
Usually the plastic guide on the motor for the cable breaks then the cable doesnt wind up properly and slides off. Only fix I know of for that is to replace the motor. I havent had to deal with that yet thankfully and may not be your issue. Just from what I've read in the past.
 

·
Registered
Joined
·
1,161 Posts
Was your truck hit in an accident on that 1 side? Maybe the doors were apart while sitting in a autobody shop and never reassembled correctly..??
 

·
Registered
Joined
·
1,161 Posts
Wait you said roll up Windows. ?
 

·
Registered
Joined
·
105 Posts
Discussion Starter · #5 ·
i took the door apart this weekend. it turns out the motor is all jacked up. the wires used to control the movement of the window is frayed and tangled inside of the motor and a few of the plastic peices were broken. looks like im going to have to buy a new motor and install it.
 

·
Registered
Joined
·
877 Posts
It's not the motor. It's the regulator. The motor is probably fine. What I did was buy a used regulator assembly (which included the motor) off ebay for like $50. It came off a newer model than mine, so it should last longer. It's basically just a bolt-on plug and play.
Looks kinda like this:


Actually, I just checked RockAuto and they have some for like $50
 
1 - 6 of 6 Posts
Top