Isuzu SUV Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
291 Posts
Discussion Starter · #1 ·
I kind of have a wierd thing going on my 98 Rodeo. When I'm on the gas, and hit 2500rpm, I hear a sound that seems to be coming front the front passenger side of the engine. It basically makes the same sound that you would hear if you drove through an area of wet pavement with only the right front tire. I don't know if any of you can really imagine that sound...it doesn't necessarily sound like splashing water, more like a leaking air sound. It was doing this when my IMG was cracked, and I thought that was the problem, but now that I have replaced them, it is still there. Would it be possible that I didn't tighten down the bolts enough? (My torque wrench read 13 ft/lb, but there is always human error!)

Any ideas?
________
silver surfer vaporizer
 

·
Registered
Joined
·
247 Posts
Dude, I think you and I share a similar problem. If you look down 10 posts or so on the "General Discussion" page you wil see a post titled "hissing noise"...that's me trying to find answers to my problem too. If I find out anything I'll post it on here, so far no luck though. One buddy of mine who's a mechanic thought it might be my tranny pump just getting noisy but I'm not sure about that prognosis.
 

·
Registered
Joined
·
291 Posts
Discussion Starter · #3 ·
Interesting...if it is the pump...in theory, the vehicle would be fine for quite a while, if not forever, without having to "fix" the problem. But...who knows if that's the actual problem!

EDIT: Hmm...well, I just read your post, and i'm not sure that they are the same or not. My sound really only happens when the car hits 2500rpm +/-50rpm or so. If I'm anywhere else, there is no sound at all...might be the same problem, just slightly different symptoms, though!

EDIT #2: After a little research...it seems that a noisy pump could indeed be a little bit of a problem. Especially if the noise is because of some particles clogging up the suction...I never really thought of it that way... Anyone else here have ideas/suggestions?
________
buy iolite
 

·
Registered
Joined
·
89 Posts
Also, consider the power steering pump. They tend to "whine" at specific RPMs. My dealer says it is common and 'normal'. I replaced mine, and the whine went away.
 

·
Registered
Joined
·
291 Posts
Discussion Starter · #5 ·
Hmm...the power steering pump, eh? I had never heard of that whining only at specific RPMs. I knew that sometimes it would just whine in general, but I hadn't heard at certain RPMs. But, I guess that is possible now that I think of it. That may be worth some looking into.
________
Popstocks
 

·
Registered
Joined
·
89 Posts
boonie45 said:
Hmm...the power steering pump, eh? I had never heard of that whining only at specific RPMs. I knew that sometimes it would just whine in general, but I hadn't heard at certain RPMs. But, I guess that is possible now that I think of it. That may be worth some looking into.
Actually, when my PS pump whined it only did so around 2100 rpm. Anything under or over that rpm and the pump was quiet. Stick a broom stick against the pump body and the other end against the side of your head, then rev it to the rpm in question, and see if you can pinpoint the noise. That's how I diagnosed my problem.
 

·
Registered
Joined
·
291 Posts
Discussion Starter · #7 ·
Interesting...I'll give that try. Thanks for the suggestion anthonyn.
________
Ford Taunus V4 engine
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top