Isuzu SUV Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My 94 Trooper S has some significant acceleration problems. It seems at times to be only running on some cylinders and during acceleration runs very rough, but will run smooth with slow Acceleration.
 

·
Registered
Joined
·
7,209 Posts
Start with a tune up. Check your plugs. Change your fuel filter and air filter. See if you are throwing any codes (Autozone should read them for free). How many miles on the clock?

Cat converter could be clogged. Are you smelling anything odd, sulfur smell?

Just throwing some ideas out there.

Joe
 

·
Registered
Joined
·
7,209 Posts
Does the 94 have coil packs? Or plug wires? If it has plug wires, start it in a very dark area and lift the hood. Look around the wires and see if you have any arcing. If so replace the wires.

Look into the cat converters you could have one clogged and it would severely change your acceleration. Did you take it to Autozone to see if you were throwing any codes?
 

·
Registered
Joined
·
454 Posts
bigpoppax2 also suggested the air filter. Did you replace that too?

A plugged air filter rears it's ugly head on acceleration. You hit the gas pedal, thereby opening the throttle plate and in comes what should be a rush of air. If the air filter is plugged, you don't get the air, but the throttle is open and the system thinks it's time to dump in more fuel. Now you've got too much fuel and not enough air.

This is but one scenario.

In the end, it will require testing to determine the cause. Pull the air filter if you haven't already and see what it looks like.
 

·
Registered
Joined
·
10,081 Posts
Well one thing is you "found" an 18 year old thread (one problem with our "new" format). So many of these ancient threads by, and answered by people who have been gone for years.
If you have a specific problem or concern, look at the date when doing a search, or just start a new thread asking about your issue. Dennis
 
1 - 7 of 7 Posts
Top