Isuzu SUV Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter · #1 ·
Ok, now that i have slowed my driving down on hwy, my next problem i am working on is my ac, i have recently had it charged, new dryer and put on new belt and tensioner, but how cold should it blow and it does not seem like it blows very hard.. what i mean is on high the amount of air does not seem that strong..

now one thing is that i donot have tinted windows and it gets hotter that hell in dallas,tx..

oh guess it would help to let you know that the vehicle i am trying not to flip over on a daily basis is a 1988 trooper ls with 2.6 4ze1 and that i am running R12 on original compressor...

any suggestions?
 

·
Registered
Joined
·
825 Posts
hmmm... R12- the old stuff(i think).... if the old equipment is still working well, it should actually be capable of blowing *colder* than modern R134 systems...

If you are noticing what seems to be limited flow... this could be related to air not escaping from the car as you try to blow it in... i've noticed that I get more air flow and better cooling if i set the lever that adjusts where the air is coming from halfway between recirculating and outside air... or... use all air from outside setting, and crack a rear window or a sunroof.. eithor option seems to increase the air flow significantly for me.
 

·
Registered
Joined
·
11,467 Posts
Get a cheap digital thermometer and put it in your vent when the a/c is on and vehicle is moving. It should be in the low to mid 40's. I think mine is low because the compressor keeps cycling off while driving. Will get to 43 then shut off, go up to 50, then kick in again. I have never had a personal car with a/c so dont know if thats normal. I know on my work van it stays a constant 41-43 as long as it is moving.

I also noticed that having the vent half way seems to work best, as well as cracking a window open. Since I'm an evil smoker :twisted: my window is usually open a bit anyways though.

Anyone know a ball park figure of getting all the windows tinted in a 2nd gen rodeo? I would like to have mine done in a privacy tint eventually. Should help with the heat and would look nice on my black rodeo :lol:
 

·
Registered
Joined
·
69 Posts
Discussion Starter · #4 ·
well problem is that i donot have recirculating option on my a/c only MAX and NORM, i have put thermometer and it reads like 40-50 depending on if i am driving or not while at stopped at a light it blows just not as cold as when i am giving it gas,

now i know it is going to be colder while giving it gas because it is compressing the air more, but if i were to put a fan between radiator and condensor so that it pulled in air just for the condensor would this help?

reason i ask is because on my honda, their is a fan for radiator and fan for condensor, and my troop only has one belt driven fan for both!!!

so what do you guys think?
 

·
Registered
Joined
·
11,467 Posts
ppfalcon said:
40-50 depending on if i am driving or not while at stopped at a light it blows just not as cold as when i am giving it gas. now i know it is going to be colder while giving it gas because it is compressing the air more,
It will be colder while driving because the compressor is spinning faster, as well as more air through the condenser.

ppfalcon said:
but if i were to put a fan between radiator and condensor so that it pulled in air just for the condensor would this help?,
No, the condenser should be in front of the radiator getting the air first. Once you get to about 15-20 mph the fan is doing nothing because the force of air is greater then what the fan would provide anyways. You can check the fins of the condenser to make sure they arent smashed or clogged with stuff. Also cleaning it might help with heat transfer. There should be a sight glass on the top of the reciever, with the engine running and a/c on max for a few minutes check to see if it is clear or has bubble (usually they are tiny and just makes it look white). If there are bubbles then it is under charged.

Btw, checked mine when I got home today and was as I thought. Lots of bubbles in the sight glass so under charged. Took 1 lb to charge it back up.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top