Isuzu SUV Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
61 Posts
Discussion Starter · #1 ·
Yep, 4 quarts in 2200 miles. It has no visable oil leaks anywhere and it's garaged so I would see them. I am new to my Isuzu but this is unexceptable. I have owned it about 30 days and I am very upset about this oil consumpsion situation. What are my options? Will Isuzu do anything? What about switching to synthetic? Any and all suggestions would be appreciated. I really like this truck but have already considered trading it in and I have only made one payment, very sad indeed.

:(

Thanks in advance....
 

· Registered
Joined
·
61 Posts
Discussion Starter · #4 ·
My factory warranty (60k) expired about 2 weeks after I bought it so this issue had not turned up yet (others did). It now has 61,500 miles and I received a Wynn's extended warranty from the dealer. It's a 3yr/36k and I will pray they might cover this.

I was blown away when I was adding oil to it last night. I was checking the floor, gaskets ect. and not a spot of a leak anywhere. Also another bothersome issue is the Isuzu oil stick, what a POS that is. Has anyone found a better replacement?. I only ask because it looks like I will be checking my oil every 3 days, freaking lovely :evil: .
 

· Registered
Joined
·
61 Posts
Discussion Starter · #7 ·
I have documented every drop of oil I have added and hopefully the Wynn's warranty will help. As expected Isuzu Corp. was of no help because I was over 60k.

In reality I like the Rodeo but have a bad feeling about this specific truck and I might bail on it. Did I mention it needs axle seals, wheel bearings and a breather kit?. Also the dealer gave me a quote of 6.8 hours to do a cracked CV boot, what's up with that? They charge $70.00 an hour so my bill for everything will be $1100.00+ and I already spent $200.00 on it in the last two weeks!

And yes it's the funky twisty oil stick, I find it very hard to put back in without having to grab middle if it and force it back in. It just seems odd to me.
 

· Registered
Joined
·
61 Posts
Discussion Starter · #9 ·
I am now averaging 1 quart of oil every 436 miles. On a positive note I am getting very good at operating the twisty dipstick! :roll: I am lost what to do about this oil consumption issue, any suggestions?
 

· Registered
Joined
·
61 Posts
Discussion Starter · #11 ·
I checked the coolant at the top of the radiator but no oil. I might drain a quart + off this weekend to look closer though and I'll post the results. It displays a very minor exhaust smoke and only upon start-up. However it does blow a bit of black soot right off. The oil consumpion is amazing! :shock:
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top