Isuzu SUV Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
Help,
My '96 Trooper with 166k randomly won't hold an idle. It basically just shuts off... no sputtering, stumbling, erratic revving, NO CE light etc. Last year it did this once when it was in the 20's (Atlanta winter) and threw a code referencing the MAF. I pulled it out and looked it over and saw minimal dirt and the wires were still intact. Put it back in and it hasn't thrown the CE light since. This is a very sporadic occurrence and turning the key off completely, waiting a minute or so, and restarting fixes it. Starts right back up with no fuss and once past the idle point runs perfectly normal.

Not real sure where to start looking. It's very annoying and slightly dangerous when you come to a stop and it just quits. Could a flakey MAF cause something like this?

Truck is in overall great shape and well maintained (not a beater).

Thanks,
Chris
 

·
Registered
Joined
·
49 Posts
i had a car once and the ignition was worn when i would hit a bump the key would roll back just enoughf to sut the motor down it took me months to figure out the problem but i got worse with time the only reason i picked up on it was because i held my hand close to the key like 1 mm waiting to have to re start it and it rooled back and hit my finger wich i imediatly thought wait a minit that aint right with closer inspection i found just the weight of my other keys swinging would cause it as wellas bumps probly not your problem but for 2 min of time its a good place to look at i bought the car with 76 000 km never been in the highway always parked in the garage with new plugs and wires and a full tank of fuel for 50 bucks it was only a hundai accent but mint it was even had all service reccords right down to wiper blades then my gf put it in to a poll lol
 

·
Registered
Joined
·
8,073 Posts
Neutral safety switch?
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #4 ·
If the MAF sensor was going bad would it trigger the CEL or not? Seems like the stalling at idle is getting worse but still no codes.
 
1 - 4 of 4 Posts
Top