Isuzu SUV Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
1,091 Posts
Discussion Starter · #1 ·
I have made a few trips up to JoeD and JPs house to get a new rear third for the RS. It was making all kinds of squealing and rumbling in the rear end. Put it up on jack stands, sound was coming from the rear diff. I took the original diff out, looks good, turns out, it is the passenger wheel bearing. It spins freely on the shaft, definitely not good.

My question, I special ordered wheel bearings with 1 yr warranty, duralast garbage. The retaining collar it came with is about half the size of the OEM collar. They pulled timken and Beck Arnley at the various local parts stores, all come with the same collar. What the hell!? Does that smaller length collar work as a replacement? Local shopis trying the press the OEM collar off, no promises. What am I supposed to do if no one has the correct collar?

Any help would be much appreciated. Perhaps the RS has an oddball rear setup, doesn't make sense to me, but who knows.
 

·
Registered
Joined
·
1,091 Posts
Discussion Starter · #2 ·
Here is a pic of what I am talking about:


I just got off the phone with JoeD, and subsequently Jerry, he said there are two different types. A thinner bearing with a thinner collar, and a thicker bearing, which would be the one I have. Looks like I got the oddball. He has the collars and bearings, no problem.
 

·
Registered
Joined
·
5,207 Posts
marlin said:
Here is a pic of what I am talking about:


I just got off the phone with JoeD, and subsequently Jerry, he said there are two different types. A thinner bearing with a thinner collar, and a thicker bearing, which would be the one I have. Looks like I got the oddball. He has the collars and bearings, no problem.
CHRIS, YOUR TRUCK HAS THE CORRECT BEARING ,,ALL TROOPER S AND THE VX FROM 88 UP USE THE SAME WHEEL BEARINGS HOW
EVER THE COLLAR IS SHORTER ON THE EARLY TROOPERS ONLY, 88-91 ,THE LATE TROOPERS AND THE VX USE THE LONG COLLAR BUT THE SAME BEARING , WILL HAVE THE LONG COLLARS IN THE MAIL MONDAY ,JERRY
 

·
Registered
Joined
·
1,091 Posts
Discussion Starter · #4 ·
As always, Jerry saves the day! Thanks Jerry! The RS should be back on the road in a few days, after all, its been sitting on jack stands in the driveway since Feb. The wife did give it a new paintjob, she herculined the bottom half, then did the UV top coat. It actually looks great, and I worked out a deal for a set of snowflakes for it as well. Just gotta get her mudders mounted on em, that should add a bit of track width and improve the "scared cat" look.
 

·
Registered
Joined
·
1,091 Posts
Discussion Starter · #5 ·
I got the shop to press of the oldbearings and put the new bearings on for 130 buck, including new outer seals! Good deal as far as I am concerned. The original collars split when he was pressing them off, no worries, thanks to Jerry, I had new ones. Got everything back together, new inner seals and all. I even put a bit of RTV on the axle tube/shaft mating surface as cheap insurance.
Problem now, I can't figure out how to get the Ebrake assembly back together...lol. Just filled the diff with the old gear oil, (only a few months old royal purple, I will drain and refill with new next weekend. I figure any dirt and whatnot that was in the new diff will be caught in the old oil. No worries)

I have a friend coming over later to help me unravel the brake mystery. If nothing leaks, I will finish up, take her for a test drive, make sure its gtg, then start on the VX, needs new front wheel bearings on drivers side, and repack passenger side. Yippee!!! Something is always broke on these trucks.
 

·
Registered
Joined
·
5,207 Posts
marlin said:
I got the shop to press of the oldbearings and put the new bearings on for 130 buck, including new outer seals! Good deal as far as I am concerned. The original collars split when he was pressing them off, no worries, thanks to Jerry, I had new ones. Got everything back together, new inner seals and all. I even put a bit of RTV on the axle tube/shaft mating surface as cheap insurance.
Problem now, I can't figure out how to get the Ebrake assembly back together...lol. Just filled the diff with the old gear oil, (only a few months old royal purple, I will drain and refill with new next weekend. I figure any dirt and whatnot that was in the new diff will be caught in the old oil. No worries)

I have a friend coming over later to help me unravel the brake mystery. If nothing leaks, I will finish up, take her for a test drive, make sure its gtg, then start on the VX, needs new front wheel bearings on drivers side, and repack passenger side. Yippee!!! Something is always broke on these trucks.
CHRIS , TAKE ONE OF THE WHEELS AND ROTORS OFF THE VX AN D LOOK AT HOW IT IS PUT TOGETHER THEY ARE THE SAME BRAKES SYSTEM, THOSE PARKING BRAKES ARE A NITE MARE TO PUT TOGETHER , IT IS SO CLOSE IN THERE . JERRY
 

·
Registered
Joined
·
4,743 Posts
Not sure if this is a problem for your axle or not - it sure was for my Amigo - and looking at your pixs, it looks the same to me.

What happened was I found that the old outer slinger would eat the outer seal instantly when I got it all together and off the jacks.

The machinist had a lot of trouble trying to save that slinger, but when he put it back on, it was the wrong thing to do.

Hopefully you don't have the same trouble as I did.

BTW: The bearing retainer must be replaced each and every time when the bearing(s) are replaced. It's the thing that holds the axle in place and failure of it if it was reused - would be pretty bad.
 

·
Registered
Joined
·
1,091 Posts
Discussion Starter · #8 ·
The shop that did it is the same shop that rebuilt my F250 rear end. They primarily work on big trucks. Good people and they stand by theire work.

As for the collar, the smaller collars are not reusable, but longer 2" collars (per Jerry).

Jerry, thanks for the tip, I was thinking that, but avoiding taking the VX apart, that thing is one hateful rust bucket. Seems everything I do on that breaks something else...lol. :twisted:
 

·
Registered
Joined
·
1,091 Posts
Discussion Starter · #9 ·
Just got it all back together. Everything seems ok. She seems to have no balls at 50mph and it took some work to get in the 70mph range. The rear hubs didn't feel hot or anything, and no noises that I could hear. It does have an exhaust problem, so it may be an excess back pressure thing. The muffler inlet is busted and kind of cockeyed, so it may have issues inside the muffler? I never really drove it anyway, so maybe it never had any balls, the VX has the 3.5 and is slow since its on 34s. The RS is sitting on 30s at the moment, so fairly close to stock.
Dunno, gotta do some more running around in it, drain the oil and refill it in a few days.

Only thing left to do is pull the ABS light bulb on the dash. No more ABS since the new rear third wasn't ABS equipped.
 

·
Registered
Joined
·
9 Posts
Same thing here. Interesting that you resurrect an old thread and I have same issue a month after you. Did you have any luck finding the larger collars?
 
1 - 11 of 11 Posts
Top