Isuzu SUV Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
My '89 trooper will start and run great for a day or so but then just as suddenly won't start at all for a few days. It doesn't stall but does run a bit sluggishly when it is running. Nothing major and it idles fine right around 950 rpm. I've changed the fuel pump and filter, replaced the wires and fuel lines (rubber). I've replaces all air lines for the emissions crap and the air filter. I've checked for fuel pressure and checked for voltage at the harness and the engine........what to do now??? Any suggestions or advice would be greatly appreciated....

dawn...
 

·
Registered
Joined
·
1,286 Posts
'89 Troop motors came in at least two flavors:

2.6 ISUZU 4-cyl AND

2.8 GM 6-cyl

Which do you have?

Secondly, what happens when you turn the key to Start?

Nothing OR

The engine just turns over and over but doesn't start?

What's the tuneup history and what's been replaced with each tuneup?

OH, AND
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
WELCOME TO THE BOARD!!!!

:D

Cheers,
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks for the welcome...As for the troop, it has the 4ZE1 2.6 engine. When it doesn't want to start, it does turn. I do a tune-up every year and replace the cap, rotor, plugs, fuel filter and oil filter whether it needs it or not. I also take it to a local quick lube every 3000 miles and they do a very thorough job. This problem is baffling the hell outa me. I hope you can tell me something useful. For now I think I will go pick some brains in town.

dawn...
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
It turns out it was the fuel pump wiring harness/connector. It had a burned out socket and so I replaced it with a trailer connector. No big deal. Now I'm having a bit of an idle problem. But I should be able to figure that one out. If I don't, then I'll be back for help. Thanks...

dawn...
 

·
Registered
Joined
·
2 Posts
humm i thought i was having distributor probs. mine will die or not start randomly, and i take out the distributor and clean it, and turn a few times until it cranks, does that sound like your issue then?
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top