Isuzu SUV Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter · #1 ·
Ok, the Trooper was running great until I went on a trip of about 150 miles. Got back home and it has been running rough and seems like it has a rich fuel mixture. Improves under acceleration, starts bucking when I let off the throttle and has a miss at idle. Seems like I have had trouble with the Trooper every time that the gas tank gets below about 1/2 tank. Could I be getting trash past the fuel filter and into the carb?

Help! Thanks everyone.
 

·
Registered
Joined
·
62 Posts
Discussion Starter · #2 ·
Here's some more information on the Troop. I went out and pulled the plugs tonight. The #1 plug looked great, the rest were black - not soaked with oil but dark black like carbon or soot. I put everything back together and started it up. I could hear a hissing sound near the black canister on the passenger side of the engine (I'm not sure what this is for). On the bottom of the canister is a large nipple - I put my finger over it and I could feel a vacuum - nothing is connected to it.

Is anything supposed to be connected to the bottom of the canister? Any other ideas?
 

·
Registered
Joined
·
62 Posts
Discussion Starter · #3 ·
Did some more research and realized that this is the charcoal canister. Like I said in the previous post, there is a nipple on the bottom pulling vacuum with no hose attached to it. Is this normal? I can't find any loose vacuum lines.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top