Isuzu SUV Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
608 Posts
Discussion Starter · #1 ·
#1 is the original 5-speed from my 2.6L isuzu pup {size is corrected}
- 1st/2nd gears don't work

#2 is from somebody else. MUA5 (i believe)
- NOTE : "bell housing" is busted. all other gears seem to work.

buyer beware : neither one work AS-IS.

I'm looking at ~$300 range for both but will probably take the first offer that tickles my fancy.
 

·
Registered
Original owner, 1983 P'up LS (diesel)
Joined
·
2,743 Posts
DogMeat said:
#1 is the original 5-speed from my 2.8L isuzu pup
- 1st/2nd gears don't work
What country are you in? The P'up was never offered with a 2.8 in the U.S., and I'm not aware of it ever having a 2.8 elsewhere. Is this 2,8 a diesel?
Edit: Oops, now I see. You're in Greensboro, NC. So it's not a diesel.

Jack
 

·
Registered
Joined
·
2,150 Posts
JoeIsuzu said:
DogMeat said:
#1 is the original 5-speed from my 2.8L isuzu pup
- 1st/2nd gears don't work
What country are you in? The P'up was never offered with a 2.8 in the U.S., and I'm not aware of it ever having a 2.8 elsewhere. Is this 2,8 a diesel?
Edit: Oops, now I see. You're in Greensboro, NC. So it's not a diesel.

Jack
I'm assuming its a mistype as he listed the truck in his sig as a 2.6l :)
 

·
Registered
Joined
·
608 Posts
Discussion Starter · #4 ·
DASZU said:
I'm assuming its a mistype as he listed the truck in his sig as a 2.6l :)
Yes: Greensboro, NC -- USA

my fault. yes. #1 is for the 4ze1 2.6 gas fuel inject 4-cyl engine.
I corrected it.

#2 came off of a V6 gas engine. I don't know anything more about that except the bell housing "ripped" due to a cut to make it fit onto a different engine followed by a massive drop off of a ledge. I'll see if I can post pics later this week.
 
1 - 5 of 5 Posts
Top